Add to footprint library

I just upgraded to 4.0.1 on Windows 10.

I can not create a new library or add a footprint to an existing library.

I will select Feducials for an example as the active library.

I will create a footprint, and give it a name, and save it in active library and the following error occurs:

IO_ERROR: GitHub library
is only writable if yoou set option ‘allow_pretty_writing_to_this_dir’ in Library Tables Dialog.

I can not find how to do the above. Thanks I advance.
Brian Fleming

Update to 4.0.4 for a start, it fixes several problems.
In library manager save the libraries to local copies, you cannot write to the GitHub libraries on the server

1 Like

OK, I upgraded to 4.0.4 but does not solve my problem.

This is what I want to do. I am using Windows 10, I want to create a footprint, and attach it to a component in my schematic.

This is what I have done.

New footprint
new footprint is named, and now I see the footprint editor, and I place one pad just for a test
click File/save footprint in new library folder is called KICAD_FOOTPRINTS.pretty and footprint is saved.
if I go to file explorer, I see the new footprint with the extension kicad_mod

Now I want to use it, problems begin here.

I open schematic, and try to edit the footprint of a component, I try to select the library, and I can not select the library which is where I saved my footprint, which Is why I tried to save it in Feducials, because at least I can select that library.

I appreciate any help you can give me.


Before you can use the new footprint on a board, the library containing the footprint must be listed in the Footprint Library Table. From the “Preferences” drop-down, select either “Footprint Libraries Wizard” or “Footprint Libraries Mangler” and add your new library folder to the list.


1 Like

Hi Dale,

My Preferences menu only has
Configure Paths
Set Text Editor
PDF Viewer
Hot Keys

You’re looking at the KiCAD Project window. Instead, go to the “Preferences” at the top of the window in “PCBNew”.

The screen capture in the post at Laying out my first board (with KiCAD) may be helpful to you.



I think I have it working now, just like I did on my old XP box. Their file structure and process for user definable files like footprints is unlike anything I have ever seen before.

Thanks for your help!


Yeah, KiCAD is running with two systems currently (symbols/EEschema use legacy variant and footprints/PCBnew uses the future version).
EEschema is being worked on right now to be like PCBnew already is.
Enjoy the ride and if you got problems, we’re here :wink: