Add routes to footprint is possible?

Hello, I am new to kicad and I can’t find how to do this:

Imagine I have a board with 2 resistors, they need to be connected in series, in the footprint I want to allow 2 valid places the resistor can be soldered (for example to make the board reversible, but for this example, I will show a single side)

so, here is the schematic:
image

I made it very simple, 2 resistors in series, but I created a custom footprint for the resistor:

notice that this is the footprint for a single resistor, but it can be soldered in one of 2 places: place A and place B, I don’t care.

then, is time to create the PCB, so here is what I have:

I connect the 2 resistors with a track…

but, I still have some ratsnest wires not connected, of course, since each resistor can be soldered in different places, I need to make sure those places are also connected, here I do it for the left one:

now, Imagine I need to replicate the same footprint hundreds of times, I quickly notice that I do not want to make the tracks inside the footprints, because is time consuming and error prone (maybe I forgot to do it in one of the footprints)

I need to find a way to add tracks to the footprint so when placed on a PCB those connections are done.

Since is not possible add tracks on a footprint, my solution is to draw them in the copper layer using lines in the footprint, like this:

then, I update my footprint in the PCB and this is what I get:

Notice how on the resistor footprint on the right kicad still shows ratsnests wires for unconnected pads even when there is a clear track of copper between them.

I understand the software limitation since those “tracks” are actually just a graphic line and not part of a pad, but how can I solve this?

How can I add tracks inside a footprint in order to connect repeated pads?, thank you very much

I do agree that it’s time consuming, but it’s not “error prone”. You will get complaints from DRC if you forgot a connection.

One way of adding the connections to the footprint itself is to draw the copper tracks as long narrow SMD pads. When the pads overlap enough, then KiCad recognizes as them being connected. If you do this with pads, then all connecting pads must have the same pad number, and you must turn off the solder mask and paste layers for the pad you want to use as copper connections.

I am not sure how you drew those lines on copper. You can do this, but you have to make the lines part of the pad. To do this:

  1. Select both a pad and your graphic lines. (hold shift while clicking, or drag a box)
  2. Right Mouse Button, and select “Create pad from selected Shapes” from the pop-up menu.

Such a custom pad may only have one “reference pad”, so add the graphics to either of the pads, and then have it overlap the other pad.

1 Like

It makes sense, I was suspecting that the only way kicad will recognize the connection is to make them pads.

but I cant find the “Create pad from selected shapes”:

I am using kicad v 5.99 (nightly)

also, here is how I draw the lines:

thank you in advance!

I was able to make it, but kicad requires to first create the pad as custom shape, and then add a single shape primitive, then, go back to the footprint editor and edit the shape from there (Ctrl-E), thanks!

Ah, V5.99.
It works differently there.

  1. Select a pad (Only a pad).
  2. RMB and "Edit pad as graphic shapes [Ctrl + e]
  3. Draw some lines.
  4. Exit the "Edit pad as graphic shapes [Ctrl + e] mode.
1 Like

thank you, it works fine, but now the custom shaped pad has a gigantic pad number written, is there anyway to hide the pad number text? or make it smaller?, anyways I will put another pad on top with soldermask and paste like I did with the pad 2 down there

thank you very much!

Pad numbers can be turned off, but it’s a general all or nothing approach: PcbEditor / Preferences / Preferences / PcbEditor / Display Options / Annotations / [x] Show Pad Numbers

(I have to get used to that Pcbnew has been rebranded as Pcb Editor for KiCad-nightly V5.99. I would have preferred a less generic name though).