Add default libraries all at once - SOLVED

I’m on a Mac
When I started Kicad the first time I must have chosen the wrong option. None of the default libraries installed. I found them all at /Users/paulbadger/Library/Preferences/kicad
and I can add them one at a time. However the dialog box won’t let me hold down shift or option shift or command shift etc add all the libraries at once. Am I missing something?

If there is not a way to do this, can I suggest that this would indeed be a really useful feature.

Is there an easy way to get the default libraries loaded? I tried deleting the Kicad preferences folder, then starting Kicad but it still didn’t trigger the first configuration box with the three options.

Any help will be appreciated.


Yes I know this question has probably been answered multiple times …
OK this worked - it may not all be necessary

I deleted:
/Library/Application\ Support/kicad

Luckily I hadn’t deleted the original dmg file so I just clicked that, reinstalled Kicad.
Then I created a new project, clicked schematic and seemed to be up and running with default libraries.

A bit of fuss but WAY less than adding those libraries one at a time. Maybe I just missed the right key combo to select more than one library in the library -> Open Library dialog - or maybe it’s missing. I would still like the answer to that question if anyone has it.

The simplest thing to do would be to:

  • Shut down KiCad.
  • Delete both the fp-lib-table and the sym-lib-table files (or rename if you want to be able to reverse your changes) in the settings folder on your system. I don’t use Mac so I don’t remember where the settings folder is hidden on that OS, but this FAQ entry should help:
  • Re-start KiCad and accept the default footprint and symbol tables.

This should get you back to square one WRT the library setup on your KiCad install.

lol. Looks like you and I were writing at the same time. :wink:

Thanks for your effort though! Maybe my time will help someone on a Mac get back on track

It did not work for me because Kicad never made the sym-lib-table files on install.

Those files aren’t created in your settings folder on install. They are created after the first time you run KiCad with them not existing. If they don’t exist you should get a window pop up the first time your run KiCad (or maybe the first time you try to access the symbol or footprint libraries, I don’t remember which). If the first option (use the default library table) is greyed out then KiCad can’t find the default libraries where it expects to find them. That is a separate issue to resolve.

Sidebar: If you look on your HDD where the default libraries are, there should be the default table files. These files are what KiCad will copy over to your settings if you choose (and are able to choose) the first option in the pop up window. AFAIK, the installer (and uninstaller) doesn’t touch your settings folder.

Kicad is not seeing them. The first option is grayed out. Hell, Kicad should know where it put them. Also it is not calling them default table files. This whole library thing is super frustrating, pain in the ass.
Here they are in the "application support library " it doesn’t see them.

You may need to verify that the KiCad paths are correct. This is a setting that I didn’t think to kill in my surgical “just delete these files” method that does get vaporized if you simply nuke the whole settings folder. Here is my KiCad paths configuration, note I have several specifically for my personal libraries. (I wish KiCad had place holders for personal libraries in the default settings to help encourage everyone to use the same name for user editable library locations. But with the new schematic format not relying on external libraries, this may become a moot point…)

I have the three paths you need to verify highlighted in the screenshot. Find the 3 paths that have the same name and make sure the full path matches where the libraries are on your system. Hopefully once this is done the automated “I need library tables” requestors will not have the first option greyed out. If this doesn’t fix that issue, I’m out of ideas.

Just a Windows user trying to help a MAC user here. :wink:

EDIT: Technically, you don’t need to verify the KISYS3DMOD path, there isn’t any library table for the 3D files. But if it isn’t correct then you won’t see any models in the 3D viewer. But with the 3D model folder being reviewed, you may as well also double check the templates folder points to the correct path on your system: KICAD_TEMPLATE_DIR

Ok here is my path screen shot;

So do I to know need to see, for example where “Kicad_symbol_ Dir” is actually located? By what appears Kicad thinks it should be in “Library / application support/kicad /library” correct?

Well, technically it would be /Library/Application Support/kicad/library because spaces and capitalization matters. (Well, I’m assuming capitalization matters since OSX is based on a Unix variant (FreeBSD?) and Unix is a case sensitive operating system.) That is the full path that KiCad thinks the default libraries are in. If that isn’t correct on your system you need to change path string to match reality. Looking at your finder screenshot (did it really need to be that big?) it does look like that path is correct.

Maybe there is a MAQ quirk that I’m unaware of, not being a MAC user… (Last time I touched OSX was back in the Tiger and Leopard days. No clue which version numbers as I’ve never been able to grock how the release code names related to version numbers.)

Thanks, will look to see if where they actually are located and see if they match the path shown, correct?

I guess I can’t figure out this screenshot thing, looked fine to me on my end.

Yeah, it wouldn’t hurt to see if the library files are where the KiCad paths think they are, and not buried another level deep in the in the kicad\share folder. But regarding the location of the default library table files…

Oh, my bad. I went to double check the location of the default library tables on my computer and I didn’t find them in the library folders. I found them in the templates folder. See the two highlighted items in this screenshot:

Looking at your screenshot of your path manager, I see some weird redirection action in the KICAD_TEMPLATE_DIR path.

Maybe someone who knows more about OSX can help you figure out what should be the path for the templates (i.e. should it be a simple path like the symbol and footprint libraries), or if that odd redirection is normal…

Any MAC gurus still watching this thread?

Here’s mine, doesn’t it appear sort like yours?

The template path on my mac is shown below. The default library table files are in that directory.

Any clue why guido has such a weird path for the KICAD_TEMPLATE_DIR starting with /private/var? See here. I don’t know MAC, but the AppTranslocation part of the path makes me wonder if it is an installer issue…

I have no idea about that weird path, but I’m sure it’s not an installer issue since there is no installer on the mac.

The user simply drags and drops folders from the install media (virtual disk) into folders on the mac hard drive. One folder goes into the Applications folder and one into the Application Support folder. The later one is a problem in macOS Big Sur because the default /Library/Application Support directory is read only to everyone except the system (it is read only to admins too).

So KiCad will have to start using the users local Application Support folder in the users home directory. There may be an API for the app to move stuff into that protected directory when it runs, or they may have to create an installer of some sort that has the system move stuff to that location.

After installing the application support folder as per dennischi in the other thread, it still appears the same as before on the line KICAD_TEMPLATE_DIR starting with /private/var.

The personal settings will not change without explicit user interaction no matter what package you install. This is on purpose! It protects users who already have kicad up and running from needing to be careful with updates.

To you this means you will either need to manually fix the paths (they are user editable) or you need to delete the kicad config folder in your users profile to make kicad think it starts from scratch. (A reset to factory default button would be awesome in these instances but such a feature does not exist)

macOS does something called App Translocation- this is to prevent an authorised application from running code linked via a relative path. The os randomises the true path to the resource to prevent an attack.

Starting with macOS Sierra, running a newly-downloaded app from a disk image, archive, or the Downloads directory will cause Gatekeeper to isolate that app at a unspecified read-only location in the filesystem. This will prevent the app from accessing code or content using relative paths.

macOS Code Signing In Depth

So should I leave it the way it is then, considering that the system created it?