A friendly heads up for nightly users [Bug testers needed!]

The developers are always warning users about the instability of nightly builds but we all know they are pretty usable and pretty fun to try it out.

This time, I’d like to let you know, especially different locale users (other than en_US), there is a critical bug in the nightlies which causes data loss in the used personal symbol libraries. It effects all of the symbols in the related library and makes them practically unusable without very time consuming modifications.

This is a rare case and known to effect three people, including me, for now. But it is pretty annoying to lose all of your personal symbol library in a blink of an eye.

So if you are a nightly (5.99) user and use different locale (doesn’t have to be system locale, just a comma decimal separator could be enough) please be careful and backup your library frequently. I strongly suggest to use an SCM, like Git.

You can find the details in this bug report:


Thanks for the heads up, the bug reporting and testing!
I was about to start to create new libraries with the nightly builds but I think I will wait a bit more :smirk:

Your help on the bug report is very important to get kicad stable👍


Tnx for the warning.
Excellent opportunity to point out the obvious:
Make Backups of every bit of your own work that is worth your time.

My experience is that the frequency of making backups depends on the ease to do so.
If you don’t have a NAS, adding an extra storage device in your PC ( SSD, uSD, USB stick) that’s always available is quick & easy and also provides redundancy against hardware failure. Just making a “Backup” directory in you home folder is a bit less robust but zero cost. (Except for the needed discipline)


Also, I should say, that I’m using KiCad nightly builds (actually, development branches) for my hobby projects for about 10 years and I only remember to experience a disturbance once but we should have in mind always this possibly instability.

1 Like

Just updated to the latest nightly and opened a project and 4 layers of zones are missing along with the parts.

Good thing I have my files backed up so I can revert back :upside_down_face:

UPDATE: The Zones are not missing! The Zone’s were just turned off so they were not visible. Very Cool!

But be sure to backup your work before upgrading KiCad because that was a Horrible feeling :smile:

Yea, this is a problem when opening some older designs in 5.99,and we haven’t thought of a way around it yet I believe.

This happens every time someone inserts new layers in the middle of the layers enum instead of inserting them at the end

Then this probably would happen almost everytime if someone adds a layer, because we generally add inner layers, not a new top or bottom :slight_smile:

But normally users dont add layer enums :grinning:

Yes, I found that the pads also had been turned off. I had a very confused moment before I checked the eye icons on the objects tab and got them turned on. :grin:

Version: (5.99.0-8791-g38abacf1ed), release build

I meant developers adding a certain kind of code, not users adding copper layers.

1 Like

Just to jump in here. This bug report needs testers! We have not found a way to trigger the behavior and we don’t even know yet where the issue is happening. If you have a moment, please try to recreate this report. If you can determine the steps needed for developers to observe this problem, you will greatly assist us with getting version 6 out sooner!


I did some testing using Win10 / (pl-PL) locale (EN for Kicad) and did not yet managed to trigger the issue. Noticed the reports were all Linux. Might be OS related?

I tried on Linux but it didn’t trigger. I would like to have complete steps and a self contained example project + libraries to rule out all installation dependent causes. The bug report was difficult to follow.

My locale is fi_FI for comma decimal separator.

Probably it is. The strangest setup is mine. It happens on the nightlies, but not on my personal build. And my personal build is using period as decimal separator, even though it is comma system wide. This prevents me to detect the root cause in step by step debug mode.

It should be using a system library which is apparently different for these builds. Maybe I’ll chase the dependencies, next.

It is really difficult because there are no definite steps to follow. It happens due to a certain kind of setup and the only visible thing is the numeric locale. All of the problematic setups are using comma as decimal separator.

But strange thing is, if you change the locale completely to en_US, this doesn’t change the result.

This is why this bug report is so full of messages. We’re just trying our best to find a clue, let alone a solution.

I’ve been thinking about proposing a new tag on gitlab (“warn-users” or similar) and a nightly feature that populates an html window in the control panel with tagged issues that are not closed, perhaps also listing which issues are resolved after the installed build.

@MuratUrsavas have you tried to reproduce the issue on purpose, using the ‘official’ nightly build?
First of all, starting with configuration that is know to throw the issue (build, version, locale setting)
And then performing some actions sequence (starting from fresh start Kicad) and checking if the error was triggered.
The original report is indeed too crowded with additional information to find out what actually happened so maybe a summary (just pure information, no discussion) would be nice.

Countless times. But couldn’t find a pattern to follow. And I’m facing this issue with official nightly, not with my own build.

We all tried almost everything we can think of, including developers. The problem still lies in the shadows and no arrows pointing at it. The only visible thing is the decimal separator is always comma in the problematic setups, but this is not enough. There should be additional parameters which triggers this issue, but still unknown to me.

Sure, here’s the summary;

If you are a Linux user and your decimal separator char is comma in your locale settings, you could get affected from this issue. My other observation is, this probably happens on the libraries which are converted from stable to the new s-expr format.

Problem happens on symbol library file save. By the time the problem occurs, the loaded library which is still open in KiCad, have the correct information. But the file gets corrupted. So something goes wrong when we initiate save. I don’t think this is related what’s added to or modified in the library. You also could get effected with a small modification, like just moving a pin and then save.

I couldn’t find a way to reproduce issue constantly. Sometimes my reproduction success rate increases to 50%, sometimes drops to 0% just like now. Wayne added some trap codes to catch the path my setup is following but no luck, working as expected.

One thing is a very light breeze for me in this case, which could lead us exit from this cave. In my own build, the decimal separator becomes period even though it is still comma in system settings. And I’ve never seen a problem with this setup working on the same symbol library. If we can find the difference between my own build and official nightly, we can find the root cause of this problem.

No, but it happens when changing a 2 layer board to 4 layers in the board setup. I have some boards without the effect, they were 4 layer to start with. Then there are boards I changed from 2 to 4 layer, and it’s there. But I cannot identify them, it’s just from memory. So basically it is wishy-washy.