8.0.2 - track width - use Net Class - regression/change/ did I mess up


I built my PCB with v7 and then moved to 8 and 8.0.1 and when selecting a trace and press E there used to be a check box that would make the trace width the size defined in the Net Class vs a manual entry…


I upgraded to 8.0.2 a bit a go and today I wanted to make some edits. As you can see in this image I have the Net selected but there is no check box to tell it to make the track width the same as the width defined in the Net Class…

Is this a change from 8.0.1 to 8.0.2? Did I change a setting some place on accident that turned that feature off (or is now off by default and I need to re-enable it)? Or do I have a config / settings file that is messed up? Or, or, or???

Thanks for the help!!

I think you are right, but I am not entirely sure. I can’t keep all the dialogs apart and I may be mixing it up with PCB Editor / Edit / Edit Track and Via Properties, which does have the option for Set to net class

Thank you, this helps but it is not nearly as convenient as just pressing E on the keyboard to make the adjustment. I can use this for now. If the developers are monitoring this, please add this function back or add/or add a short cut icon.