7.0.10 schematics: I can't move the pin names where I want

I want to move the pin names where I need to be, not where it is imposed.
It seems it’s not possible. Also into the editor of the component it’s not possible. I don’t find the way.


Left mouse button click to select, then left mouse button hold down and move mouse. Hold Ctrl key down after starting the move to defeat grid.
Or, hover mouse over text and press M, then left mouse button etc. as above.

It’s not a text box. It’s the pin name I assign into the Symbol Editor. And even by holding down the left mouse button with CTRL, I can’t move it. So I tried to move into the Schematics but also there is impossible.
With your suggestion I move the component. Which is not what I need. The name RT should be visible and positionable but I’m not able.

Either your picture or your description is misleading.

In the picture you have marked the reference designator. The Refdes can be oved, see @jmk.

The pin names OTOH can’t be moved in the schematic design.
Even in the symbol editor there is only one generic parameter for all pin names per symbol: pin names position offset (accessible with the symbol properties dialog)

related open gitlab issues (albeit both are affecting the symbol editor - subsequent editing the pin/pin position in the schematic editor is not covered):

The picture has the PIN NAME in evidence … not the reference designator in both cases

the first one I indicated the R (of the word RT … the T is not visible due the color of the body)

The second one I opened the symbol editor to show that RT is hidden and not movable in the schematics nor into the symbol editor.

The pin name will not move.

Your best choice in this:

Enlarge your rectangle to surround the pin name and use "fill with body background color… any color except the color of the text. ie. in your case, not black.

1 Like

If you want a movable text “RT”, insert a separate text object and hide the pin names for that symbol (symbol settings). To hide a single pin name you can set the font size to zero (pin settings)*.
Perhaps I misunderstood what you trying to achieve…

EDIT: *) No warranty. Possibly not recommended.

1 Like

Thank you . I did try to put the TXT inside the symbol editor to have it each time as I wish respect the symbol itself.
It worked out. Thanks a zillion. It’s a good workaround I didn’t think about.

No need for zillion thanks :smile: . Just mark the solution to help others navigate easier through this forum :wink:

1 Like

This does seem to work, but I find it an unintuitive solution. If you don’t want pin name text, then just remove the text from the pin name. (and use some other text string to add text).

Yes, that’s unintuitive. I think I found that method in the bundled KiCad libs - perhaps not that recommended but works. On the other side in the pin list/table the pin name isn’t empty and (correct me if I’m wrong) net labels still work with that.
In general this is a rare situation where pin names should be moved to non-default locations.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.