6.0.5 build failed in ppa?

Hey there. I really need KiCAD 6.0.5 because of a bug fix. But the build for the ppa failed so there is no up to date package available. Any ideas? I believe it would also fail if I build it from the source.

Be a bit patient?

Apparently it was officially released two days ago

The windows version seems to be available for direct download:

The KiCad website install instruction for (most?) Linux distro’s still mention KiCad V6.0.2

I am a bit surprised about this though.
In previous versions I often got updates via apt before the new version is officially announced. This prevents people complaining about released versions they can not find (yet).

Edit:
“Installers” → “KiCad website instructions.”
@ML9104 Oops, my head was not attached to my hands when I typed that.

Yeah, me too. The flatpak version is also already v6.0.5. Who knows ^^

We only wait for Windows and macOS that make up the majority of our users AND we have direct control over the build process and build times on these platforms.

I opened a issue for this.

Would be interesting to the usage stats of Win vs Mac vs Ubuntu

6.0.5 is now out for Ubuntu 22.04
Looks like builds are still failing for the other versions of Ubuntu

Me to on Linux Mint:

paul@cezanne:~$ sudo apt upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
The following packages will be upgraded:
  kicad kicad-demos
2 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 49,6 MB of archives.
After this operation, 333 kB of additional disk space will be used.
Do you want to continue? [Y/n] 

I now have:

Application: KiCad

Version: 6.0.5-a6ca702e91~116~ubuntu20.04.1, release build

Libraries:
	wxWidgets 3.0.4
	libcurl/7.68.0 OpenSSL/1.1.1f zlib/1.2.11 brotli/1.0.7 libidn2/2.2.0 libpsl/0.21.0 (+libidn2/2.2.0) libssh/0.9.3/openssl/zlib nghttp2/1.40.0 librtmp/2.3

Platform: Linux 5.13.0-27-generic x86_64, 64 bit, Little endian, wxGTK, xfce, x11

Build Info:
	Date: May  4 2022 07:55:51
	wxWidgets: 3.0.4 (wchar_t,wx containers,compatible with 2.8) GTK+ 3.24
	Boost: 1.71.0
	OCC: 7.5.2
	Curl: 7.83.0
	ngspice: 36
	Compiler: GCC 9.4.0 with C++ ABI 1013

Build settings:
	KICAD_USE_OCC=ON
	KICAD_SPICE=ON

On Lubuntu I’m on 6.0.4 through normal APT upgrades. Works fine.

Issue I raised has also been closed. Ubuntu download section has now been updated to reflect 6.0.5

1 Like