6.0(.0) accelerated graphics question caused crash

When opening a schematic file for the very first time in 6.0(.0), a pop-up asked if I wanted to “try accelerated graphics”.
I chose yes and the programme crashed. I tried this three times with the same result.
Choosing “Not now” allowed 6.0(.0) to open, and the pop-up no longer appears on opening and all is good so far.

I’d like others to try and then comment please.

Application: KiCad

Version: 6.0.0-rc1-unknown-9238b27f63~144~ubuntu20.04.1, release build

Libraries:
wxWidgets 3.0.4
libcurl/7.68.0 OpenSSL/1.1.1f zlib/1.2.11 brotli/1.0.7 libidn2/2.2.0 libpsl/0.21.0 (+libidn2/2.2.0) libssh/0.9.3/openssl/zlib nghttp2/1.40.0 librtmp/2.3

Platform: Linux 5.4.0-90-generic x86_64, 64 bit, Little endian, wxGTK, cinnamon, x11

Build Info:
Date: Nov 17 2021 09:48:50
wxWidgets: 3.0.4 (wchar_t,wx containers,compatible with 2.8) GTK+ 3.24
Boost: 1.71.0
OCC: 7.5.2
Curl: 7.68.0
ngspice: 31
Compiler: GCC 9.3.0 with C++ ABI 1013

Build settings:
KICAD_USE_OCC=ON
KICAD_SPICE=ON

Have earlier versions worked for you on the same system? What’s your system exactly? What graphics driver are you using? Can you choose accelerated from Preferences successfully after opening KiCad?

Yes.

Yes

nvida-driver-470
version470-82-00-0ubuntu0.20.04.1
NVIDIA driver metapackage

Have you rebooted after updating the graphics driver? I suppose you have updated recently because I had to do that, too, and before I did after updating the kernel, KiCad crashed.

There is a related issue. https://gitlab.com/kicad/code/kicad/-/issues/9589

Please try to run ‘glxgears’ and post the output.

Sorry missed that question:
Nvidia GK208B [GeForce GT710] graphics card.

As I said in the OP, the problem ONLY occurred the VERY FIRST time I opened 6.0.0.
The problem hasn’t occurred since, even after rebooting.
Also, other Linux downloads required a reboot, so the computer had rebooted before I first opened 6.0.0.
Possibly the only way to repeat the problem will be to delete 6.0.0 and download again.

If the problem can be repeated that way on an up to date Ubuntu system it’s worth reporting.

BTW, it’s not 6.0.0 yet, it’s 6.0(.0) rc1. 6.0.0 will be the actual final release.

I will try later this evening when the internet quietens down. We are way out of town so still on ADSL2, not Fibre.

I really didn’t care a rat’s posterior, but some trying Kicad for the first time may find it an annoyance… perhaps “unprofessional”? :slightly_smiling_face:

Sorry, I didn’t even notice the (.0)… Made a few edits.

Before you reinstall try checking if simply deleting kicad settings directory (probably in your ~/.config) will reproduce the issue. If you do reinstall delete the settings too.

2 Likes