5.99: need help with private MSVC build and python

After quite a while I did a private KiCad build (MSVC) again.
Compiled ok.

When running the installed Kicad, I get a “Failed to import the site module” error from Python.

I have no Python installation other than KiCad’s on the machine, the registry is clean as well.
The environment in launch.vs.json seems to be correct as per the documentation.

Help appreciated :pray: :slight_smile:

Well, I run kicad.exe (install) debug/release builds from MSVC. To do that you need to structure the /install-{blah}/bin folder with the python files copied over from vcpkg. (Look at the nightly install for a hint)

To run the non-install builds…I’m not sure where the correct path is but @craftyjon might know.

I run kicad.exe(install) from MSVC as well. Thanks for the hint.

I do not care about non-install builds, so @craftyjon, please don’t invest any effort in that.

Thx for now.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.