[5.99] Cannot Align Pads in Footprint Editor

Should I be able to align footprint pads in the Footprint Editor? I’ve tried and there is no change in any pad location.


Application: KiCad Footprint Editor

Version: (5.99.0-10337-g2ae264751f), release build

Libraries:
wxWidgets 3.1.4
libcurl/7.74.0-DEV Schannel zlib/1.2.11

Platform: Windows 10 (build 19041), 64-bit edition, 64 bit, Little endian, wxMSW

Build Info:
Date: Apr 17 2021 00:08:28
wxWidgets: 3.1.4 (wchar_t,STL containers)
Boost: 1.75.0
OCC: 7.5.0
Curl: 7.74.0-DEV
ngspice: 34
Compiler: Visual C++ 1928 without C++ ABI

Build settings:
KICAD_SCRIPTING=ON
KICAD_SCRIPTING_MODULES=ON
KICAD_SCRIPTING_PYTHON3=ON
KICAD_SCRIPTING_WXPYTHON=ON
KICAD_SCRIPTING_WXPYTHON_PHOENIX=ON
KICAD_SCRIPTING_ACTION_MENU=ON
KICAD_USE_OCC=ON
KICAD_SPICE=ON

You can select a bunch of graphic items, then right-click to bring op the popup menu and use Align / Distribute, and I assume it should work similar as in Pcb Editor.

I had a quick peek at it, both in V5.99 and in V5.1.9 and they do not work the same. Apparently there are bugs there in V5.99, but at this moment I’m not in the mood to investigate further.

As an alternative, you can first select a single pad, and then from the same popup menu under [RMB] / Special Tools / Create Array With the array function you can make a 2 dimensional array of pads and at the same time set the distance between pads, and the order of the numbering and some more options. You will probably need to experiment with all those options.

Thank you for the response. I ended up doing it one by one :frowning: But not a big deal.