5.1.7 Rotate used, should not occur - continue or start from beginning once more?

Selecting everything at PCB and executing Move Exactly I get messages:
“virtual BOARD_ITEM::Rotate used, should not occur”
After accepting it three times everything is correctly moved.
Do you have any idea what is the reason and should I be afraid that I may get into bigger problems when PCB will be finished.

That PCB history is not typical. First idea was to make it 4 layers with elements at both sides. Then I decided to make it as two 2-side boards then placed one to another touching with their GND sides. So I changed in Board setup from 4 layer to 2 layer. I selected all elements at bootom and flipped them then I had to rotate that flipped selection (to not to have them to place once more one after another). I would not see in it any special except that I rotated it and then when tried to move everything it tells me something about rotation.

Application: Pcbnew
Version: (5.1.7)-1, release build
Libraries:
wxWidgets 3.0.5
libcurl/7.71.0 OpenSSL/1.1.1g (Schannel) zlib/1.2.11 brotli/1.0.7 libidn2/2.3.0 libpsl/0.21.0 (+libidn2/2.3.0) libssh2/1.9.0 nghttp2/1.41.0
Platform: Windows 7 (build 7601, Service Pack 1), 64-bit edition, 64 bit, Little endian, wxMSW
Build Info:
wxWidgets: 3.0.5 (wchar_t,wx containers,compatible with 2.8)
Boost: 1.73.0
OpenCASCADE Community Edition: 6.9.1
Curl: 7.71.0
Compiler: GCC 10.2.0 with C++ ABI 1014

Build settings:
USE_WX_GRAPHICS_CONTEXT=OFF
USE_WX_OVERLAY=OFF
KICAD_SCRIPTING=ON
KICAD_SCRIPTING_MODULES=ON
KICAD_SCRIPTING_PYTHON3=OFF
KICAD_SCRIPTING_WXPYTHON=ON
KICAD_SCRIPTING_WXPYTHON_PHOENIX=OFF
KICAD_SCRIPTING_ACTION_MENU=ON
BUILD_GITHUB_PLUGIN=ON
KICAD_USE_OCE=ON
KICAD_USE_OCC=OFF
KICAD_SPICE=ON

It’s a bug. But it doesn’t automatically mean you will get into trouble. If the board looks OK and the gerbers are OK, then there’s no problem. Can you share a project and tell exact steps, or even reduce the board to a small example?

I was in big hurry when got that (it was 10 minutes later than I promised to be at home and I was still at work) so decided to write - may be someone knows…
I even not checked if after reopening KiCad it is still the problem - I will check it. Then I will reduce the pcb to find what triggers that.
In meantime I’ve got an idea that may be the Edge.Cut line that was (unintentionally) flipped and rotated together with my selection don’t like it (when noticed I didn’t flipped it back but only moved). Here at home I have a copy of that PCB just before that operations so I tried that and didn’t get that bug. Of course at work I was doing some more things including changing in schematic and updating PCB to it (to separate PCB into two without connections between them). I’m not able to tell exact steps I have done from PCB having no problem with Move Exactly to PCB having that problem. I was switching layers visibility on and off so may be my selection was not exactly as I supposed it was.
I suppose the only what I will be able to have would be the simplified PCB having that problem but not the step by step information how I got it.

I come back to this to find that after rerunning KiCad that bug disappeared. So I have really nothing to report :frowning: