5.1.12 crashes on W7 x86_64


Thanks for the replies.

I downloaded and installed kicad-5.1.12_1-x86_64.exe for my x64 system and while the program does start, opening the schematic editor causes the program to crash.

Kicad.exe has stopped working
Close the program.

So I’m looking for an earlier version I would imagine.

EDIT: Just tried kicad-5.1.10_1-x86_64 and that crashes as well.

I’ve split off your problem report to a new topic.

Honestly though I don’t like your chances of resolution as this is 2 (soon to be 3) versions behind, that release is no longer developed, and many people don’t even remember what v5 was like. Good luck.

I’ll just have to keep trying different versions until something works. KiCad must have made at least one version that worked while win7 was current. I don’t think the software was that bad, even way back when.

Shot in the dark but try updating your graphics drivers, or switch to fallback graphics instead of accelerated.

It may be your W7 environment. Maybe you need to have the latest DLLs before EOL. Maybe as said you need the latest graphics drivers. And so on. W7 came out in 2009. That’s an eternity ago for software. I was a workingfeline then.

1 Like

Or maybe there is something changed in your W7 system since KiCad V5 reached end of life.
V5 release lasted from January 2019 as V5.0.x and then March 2019 as 5.1.x until November 2021

W7 support ended Jan 2020, so I am surprised that 5.1 was intended to work on it

Wouldn’t the installer check for dependencies? You would hope so.

It’s now 02:53 AM and I’ve been at this all weekend. Wasted a whole weekend trying to get KiCad to run.

Time to try another product.

Thank you for your replies anyway.

Or a modern computer.

It is incredibly hard to predict what future OS changes might do to mess dependencies.
Make the checking strict and you end up with a lot of false positives. For example there are a few strains of Windows 10 in use at this time, checking each in detail would be a challenge