[5.0.0] SMD component mounted on back side


#1

Hi
One of my projects have some SMD components on the back side of PCB (2-layer)
In 4.0.7, I’ve used normal “front” footprints, and selected “Board side: Back” for footprint properties. This way my “Front” (footprint definiton) pads have been placed on Bottom copper.

However, if I open my PCB in 5.0.0, these components are invisible. They are there (you can find them using Ctrl+F, the copper plane avoids them) but they are not visible on the bottom nor on the front layer.
In the same project I use also few compoents that are placed on “Front” (Footprint properties > Board side: Front) but are defined with “Back copper” pads (so kind of “special back footprints”). This was done before I’ve noticed I can move the whole Footprint to Back side, and these are rendered OK in 5.0.0.
The same happens in Legacy and Modern toolset.
Am I missing something?


#2

Have you got all the visibility options turned on? A screen shot / sample file might help.

There is no reason to design “bottom” SMD footprints, they are exactly equivalent to a regular “front” symbol that has been flipped.


#3

Shame on me… Footprints back in the Items were deselected in my project - thanks for suggestion. On the back, most of my footprints have “back pads” (my “old” approach) and these have been rendered properly, which misleaded me…
Thanks bobc!


#4

I was going crazy with the same thing and reading this it still took me a bit to figure out where I was going wrong (actually, I was writing a post to ask “Where are the ‘Visibility Options?’” when I figured it out!

Just in case someone else is like me, here’s a screenshot showing where to change this:

Selection_014

Cheers, and thanks!
Paul