3dmodels folder missing on latest 5.99 daily

I used the nightly “lite” version to install on top of my last version and the 3D models went away. I noticed that in my path to C:\Program Files (x86)\KiCad\5.99\share\kicad, there was no 3dmodels folder. I downloaded the zip from GitHub and it was HUGE! I don’t remember doing this before. Did the lite version remove a folder? Is what is included in the 5.99 download a subset of the full number of files in GitHub? It doesn’t look like anything has been changed on GitHub for 5 months.

Also noticed that if I run ERC in the schematic, it now can’t find my symbols. Example, “symbol ‘1N4004’ not found in symbol library ‘diode’” which I believe is another folder missing from …/5.99/share/kicad. Looks like I have no “modules” folder by looking at the paths.

  1. We do not use GitHub anymore, if you download content from it, you will get old stuff. We are strictly GitLab based.
  2. Lite does not ever contain libraries, that is why it is “lite”.
  3. Lite is supposed to be additive. It will install over full versions and leave behind libraries already present. There is infact no logic in it to delete existing library files.

5.99 Full should be installed before Lite. Installing Lite on top of 5.1 does not get you libraries.

1 Like

Very confusing for me then since I was using it before. Perhaps I made a mistake and didn’t notice. Here is my folder structure:

image

I don’t have a 3dmodels, modules, or library folder.

If I just install the full version again, will it come with all 3 of those folders? I installed the full version the first time and that last 3 times, just used the lite version. Guess I need to remove the GitHub path then too?

Yes.

Technically the lite installer also asks you if you want libraries in the “components” selection screen and it will download libraries.

I’ve been *&^%$#@! a bit with installing KiCad (again) today, and after a full re-install of KiCad-nightly the 3D models did not show in the 3D viewer. KiCad defaulted to the “Aaa” path, (which did not work) and after searching for the real location of a 3D file, I changed it to the “Bbb” path, and it worked again.

Aaa: KICAD6_3DMODEL_DIR /usr/share/kicad-nightly/3dmodels/
Bbb: KICAD6_3DMODEL_DIR /usr/lib/kicad-nightly/share/kicad/3dmodels/

The paths above will not work for you, but you can still search for the location of the 3D libraries on your system and then point the environment variable to it.