3D Viewer - Weird Dimension Appears

When using the 3D Viewer, a Dimension (in White) shows up. Don’t know where it comes from.

A bit of problem solving shows erratic behavior BUT, it’s not one of my dimensions and it doesn’t disappear with hiding comments layer or deleting my dimensions.
If I deleted everything, it goes away. Piece-mealing the deletions shows that the last set of dim is somehow related…

Attached video may help demonstrate…

Can you share the .kicad_pcb file?

Attached… thanks

pcb_WslotPLAY.kicad_pcb (28.0 KB)

Argh! The same forum bug again, we can’t download it. Zip it and attach again.

Attached Zipped file…
pcb_WslotPLAY.kicad_pcb.zip (5.0 KB)

Also, another question (rather than a new post): I’ve made several 3D models (using Freecad). All works well except that when loading/setting up the 3D links, I need to scale down my WRL files (from 1.0 to 0.4). There is no ability in FreeCad to change export wrl scale and I see nothing in Kicad to do this… ?

Using KiCad 5.1.5 - 0

There is a dimension on the bottom silk layer Line 544 in your file:

  (dimension 3.41877 (width 0.12) (layer B.SilkS)
    (gr_text "3.419 mm" (at 58.42 106.68) (layer B.SilkS)
      (effects (font (size 1 1) (thickness 0.15)))
    (feature1 (pts (xy 60.129385 49.53) (xy 60.129385 105.996421)))
    (feature2 (pts (xy 56.710615 49.53) (xy 56.710615 105.996421)))
    (crossbar (pts (xy 56.710615 105.41) (xy 60.129385 105.41)))
    (arrow1a (pts (xy 60.129385 105.41) (xy 59.002881 105.996421)))
    (arrow1b (pts (xy 60.129385 105.41) (xy 59.002881 104.823579)))
    (arrow2a (pts (xy 56.710615 105.41) (xy 57.837119 105.996421)))
    (arrow2b (pts (xy 56.710615 105.41) (xy 57.837119 104.823579)))

My guess is you had started your board, put the dimension on the silk layer and then disabled bottom silk in the board setup


Thank you! That was it…

How about answer to question re scaling WRL ??

Use stepup to export 3d models as it scales the wrl model to the correct size

KiCad expects 1 wrl unit to be equal to some imperial size so you really need to scale be 1/(254*10^x) with x some number i no longer know off the top of my head

Thank you - not sure I’ll bother with Step-Up 0.4 works well enough (of course, with degrees in Eng & Math, determining ‘X’ is easy but would still need to enter on 0.4 :grinning:

The handy thing about Step Up is that it will take your input model, scale and rotate it to fit your footprint and export both a dimensionally accurate step model as well as a renderable vrml model. If you are using FreeCad anyway it seems counterintuitive to do the scaling in one application and any translation necessary to align the model in another application (KiCad). Step Up offers an awful lot more functionality too but the interface is easy to use.

The scaling factor is the reciprocal of 2.54 i.e 1/2.54 to convert from imperial to metric and is actually 0.3937 and not 0.4.

• re 0.4: Yes, correct - was too lazy to explain that it relates to 0.1inch = 2.54mm.

• I installed Stepup and exported a file. Simple enough and perhaps useful down the road…

thanks, all

You can scale 3D models in KiCad while applying it on 3D viewer.
If you want change VRML file, you can edit with a text editor the file and apply a scale.
The VRML format is easier just by following some tutorials:

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.