3D Viewer Unusably Slow


#1

Hello,

I’m using Arch with i3 and I’m trying out the new 3D viewer. It’s horribly slow. Rotating the board by more than a couple 10’s of degrees causes the application to hang for about 6 seconds and then it begins to respond again. Turning off more and more layers, like soldermask, for instance, helps, but doesn’t cure the issue.

I’m running an Intel graphics card on a Dell Latitude E6420 and I’ve got the xf86-video-intel and the mesa-libgl packages installed.

It appears (although this is pure speculation because I’m not sure where to look) that there is simply no hardware acceleration for 3D rendering enabled whatsoever. The slightest update in the scene causes KiCad to choke, big time.

Any ideas?

Thanks!


#2

What version of KiCad? POVRAY in “current” is slow…but beautiful


#3

Version: 4.0.4-stable, release build
wxWidgets 3.0.2 Unicode and Boost 1.62.0
Platform:: Linux 4.8.4-1-ARCH x86_64, 64 bit


#4

As @davidsrsb was suggesting, make sure you set the rendering engine to “OpenGL” in the preferences menu of the 3D viewer.


#5

That’s a strange looking screenshot…This is what I have:

Is the 3D viewer bundled separately?


#6

I am on the daily builds PPA, I think the raytracer isn’t even available on the stable version so I guess that’s not the issue.


#7

It’s not slow, it’s the video driver crashing periodically. At least that is what happens on my thinkpad with Intel graphics. Started happening around 4.0.2, maybe 4.0.3. Haven’t tried the development branch on that laptop.


#8

The code uses OpenGL to render, so there’s something going wrong somehow/somewhere. Check if there is a bug report at https://bugs.launchpad.net/kicad and put in a bug report if there isn’t one. Unfortunately we can’t check code on the variety of graphics controllers out there and occasionally problems show; sometimes the problem is with the graphics hardware itself.


#11