3D viewer - severely distorted picture


Have just completed my first project and progressed through creating a schematic, PCB layout and run a successful DRC check.

Now that I’ve completed the above, I’d like to view the project in 3D. the trouble is that when I select the 3D viewer - I get a severely distorted picture.

Being a newbie, I’m still getting to grips with Kicad so I may have inadvertently made a mistake somewhere - thoughts anyone??

Look forward to your responses.


Chris bw41101

Looks like some GPU incompatibility.
What OS / KiCad version are you running. Paste the info from Help / About

What GPU do you have? Are your graphics drivers to up date?

The screenshot here looks very similar to your issue:

It’s for a older version of KiCad but points to a old GPU card/driver issue.

I had a similar ragged 3D view in the past. This breakage also happened with Flightgear, which uses OpenGL.
After much experimenting with drivers and BIOS settings, I eventually solved it with a new graphics card. I suspect the old one had a hardware fault

Greetings and thanks for the responses.

Firstly, running Linux Mint 19.3 (32 bit version) on an Asos twin Xeon motherboard. I originally tried to download Kicad V7 from the Kicad website but (instead) ended up with Kicad V6? - Guess V7 is only works for 64 bit architecture motherboards - basically what you can see is what was downloaded? Requested info below:

Application: KiCad

Version: 6.0.0-rc1-bf2b03b42f~115~ubuntu18.04.1, release build

wxWidgets 3.0.4
libcurl/7.58.0 OpenSSL/1.1.1 zlib/1.2.11 libidn2/2.0.4 libpsl/0.19.1 (+libidn2/2.0.4) nghttp2/1.30.0 librtmp/2.3

Platform: Linux 5.4.0-150-generic i686, 32 bit, Little endian, wxGTK, mate, x11

Build Info:
Date: Nov 19 2021 15:42:34
wxWidgets: 3.0.4 (wchar_t,wx containers,compatible with 2.8) GTK+ 3.22
Boost: 1.65.1
OCC: 7.5.2
Curl: 7.58.0
ngspice: unknown
Compiler: GCC 7.5.0 with C++ ABI 1011

Build settings:

Graphics card info below:

Unfortunately, I’m stuck with the Nouveau drivers for the graphics card. I tried to use Nvidia drivers, but this turned out to be an unmitigated disaster and a lot of hassle to reverse - never again - LOL!

If it turns out that the 3D viewer issue is down to the graphics card - then I’ll just have to learn to live with it, sigh…!

Thanks to both respondents for the input.


Chris (bw41101)

you may try to disable accelerated graphic in kicad pcb

select the Fallback graphics as Rendering engine

1 Like

A few issues here which is giving you a world of pain, and only likely to get worse.

Linux Mint 19.3 - is now EOL.
Not sure what hardware you have but inless it’s seriously old and only supports 32 bit, there is no reason to run a 32 bit OS anymore.
KiCad 7 as far as I know only support 64 bit on Linux (Not sure about Windows, probably true there as well)

Most software vendors now only support 64 bit. You might be having Nvidiia driver issues also due to the 32 bit / EOL issue.

If the suggestion above doesnt help then I think you are out of luck. It’s certainly a GPU driver or GPU hardware issue.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.