3D Viewer not working when F.Cu invisible

Hi Folks,

with F.Cu layer switches invisible, the 3D viewer pos up (alt+3), but does not show the PCB.
Bug or feature?

Application: KiCad PCB Editor x64 on x64

Version: 7.0.1, release build

wxWidgets 3.2.2
FreeType 2.12.1
HarfBuzz 5.0.1
FontConfig 2.14.1
libcurl/7.83.1-DEV Schannel zlib/1.2.13

Platform: Windows 10 (build 19045), 64-bit edition, 64 bit, Little endian, wxMSW

Build Info:
Date: Mar 11 2023 03:41:46
wxWidgets: 3.2.2 (wchar_t,wx containers)
Boost: 1.80.0
OCC: 7.6.2
Curl: 7.83.1-DEV
ngspice: 39
Compiler: Visual C++ 1934 without C++ ABI

Build settings:

I have 7.0.1 at Windows 10 and even I switch F.Cu to be invisible 3D viewer shows my PCB.

I found out, that 3D is there, but paned far away.
Having F.Cu visible, the 3D PCB is centered from the beginning.
Strange, but nothing to put effort in, at least to me.
Maybe if others encounter the same, we should raise a flag.

You can put a zero coordinate point anywhere on the board

1: I’ve tried that, makes no difference
2: That does not explain why the behavior differs depending on wether F.Cu is visible or not.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.