3D viewer my colours look awful

I have the defaults set on the 3D viewer but dosent look good at all, I have sat and played with board body colour and the two tone background but cant get a look I like is there a set of numbers people like ? can they be loaded in as a theme file or something or do you have to mess around I just cant get the stack up to look nice like a real PCB. Any thoughts peep’s ? I am using KICAD 6 and the latest release on a Windows 10 machine

You may want to add version and os information. This could be something like a graphics driver, hardware, combo of, etc?

Thanks, I have added those details to my post.

Which operating system?

do you have realistic mode enabled in 3d viewer?

Thanks ! I have added windows 10, thats as much as I no about the PC

Don’t think so, I’ve never used that before version 6 and will check.

Hi @mousey

For future reference, to find the details other posters wanted:
Open Kicad, up the top click “Help”, then “About Kicad”.
In the top right hand corner is a button “copy version info”.
Left click that, then Copy into your post on this forum. :slightly_smiling_face:

1 Like

Thanks I can see how that would help and will do !

1 Like

Is there any way of changing the colours? Can’t say they are bad but they look a bit washed out.

Application: KiCad (64-bit)

Version: (6.0.9), release build

wxWidgets 3.2.1
libcurl/7.83.1-DEV Schannel zlib/1.2.12

Platform: Windows 11 (build 22621), 64-bit edition, 64 bit, Little endian, wxMSW

Build Info:
Date: Oct 29 2022 23:44:28
wxWidgets: 3.2.1 (wchar_t,wx containers)
Boost: 1.79.0
OCC: 7.6.0
Curl: 7.83.1-DEV
ngspice: 37
Compiler: Visual C++ 1929 without C++ ABI

Build settings:

The colours (as well as thickness and material) are set in the board stackup dialogue. “File” > “Board Setup…”

There is a separate dialogue for specialised finishes & edge connectors.

You can also choose the render the image using raytracing by clicking the highlighted button (much slower but much more detailed and accurate colour rendering.

1 Like

Thanks. Do you know where the user-defined copper finish is set up?

No, although I’m struggling to think of any options beyond the ones in the drop down.

Maybe here:

1 Like

Brilliant. I went into the Raytracing rendered and noticed the light all looked rather dark. When I reset them to the defaults it looks a bit different.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.