3D viewer is very slow

Version: (5.1.5-0), release build on custom hardware running Mac.

3D viewer is very sluggish and unresponsive at about 7 fps with or without hardware acceleration. I booted the same hardware into windows and 3D viewer ran flawlessly. Also hardware acceleration is working very nicely in Mac for pcbnew and eeschema. So I assume this means that for some reason hardware acceleration isn’t working for 3D viewer? Any suggestions would be greatly appreciated.

I lack a Mac to cross check, but just to clarify, it does not have ray tracing turned on?

1 Like

Yes ray tracing is turned off. It’s also worth mentioning that my MacBook had no issues with 3D viewer, I guess the problem must arise from it not being typical Mac hardware. However it is confusing that openGL works fine with pcbnew and eeschema and I have benchmarked openGL with normal results.

OpenGL on other platforms just like DirectX on Windows are disastrous minefields by their legacy and design because of drivers. You may find something works most of the time and the simplest of rendering out of everything you can do with it (even playing game) blows up because of a specific driver version. There was a really nice article somewhere on the net by a gpu driver dev once about how much of an shear abomination it all is.

A hackintosh may not be the best thing to use with KiCad. Drivers are already tailored to their exactly specific hardware and using other hardware just may have a slew of driver issues that you can’t fix :confused:

Note: There’s no such thing as a hardware acceleration option for the 3d viewer, it either uses opengl rendering or you just end up with a crash as it absolutely requires it.
Only the 2d rendering parts of KiCad have a “non-hardware accelerated” option to render on the CPU.


Ok thank you for clarifying, I guess I’ll just have to live with it. I did notice today oddly enough that the in the footprint editor under the 3D settings tab of the footprint properties the preview of the step model seems to work properly.

Is it possible that some of the component 3D models on the board is very complex, causing the lag? Does this happen with all boards/components?

That can’t be the problem because when I tested the same board on windows and MacBook, it worked fine there.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.