3D viewer does not follow rendering rules from Pcbnew

I have a fairly densely populated PCB where I can’t fit all component references on the silkscreen, so I’ve chosen not to render references and values and add my own silkscreen where needed (logo, revision text etc.).

This translates nicely over to the production files/gerber plots, but not to the 3D Viewer. All silkscreen components are rendered or not rendered, so I have to choose between viewing everything or nothing.

Is there a way to only render (in 3D Viewer) the silkscreen that I choose to render in Pcbnew?

I don’t think so unfortunately.

But maybe @maui, @kammutierspule or @cbernardo do know something different?

I am not sure if I follow correctly.
It is true that 3D Viewer is not following completely the Pcbnew.

Did you set the text you do not want to invisible?
Uncheck in Pcbnew the show/hide references or values is different to set individually if the reference/value must be visible or invisible.


It never occurred to me to put the text properties to invisible, since I could so easily uncheck “references” and “values” under Visibles->Render tab in Pcbnew. It did just what I needed.

Is there a quick way to set this property of many footprints at once? Or to set references/values of all footprints to invisible?

I believe there is anyway to set it.
That is a parameter specific to the footprint, so you have to set it when create a footprint. So you have to change in the footprint library and will affect all designs.

Alternatively, you could open the file as a text file, and do a massive find&replace. I haven’t tried it for this purpose, but it usually works well in KiCad for tasks that you want to automate.

Don’t forget to backup the file beforehand. And when you are done, manually revert to visible the few fields that you want to display.

1 Like