3D Viewer - back of board ray traces darker than front [SOLVED]


#1

I am using the latest (6.0.0 rc.1) nightly build of KiCad running on Windows 10. The 3D Viewer works perfectly well. However, when I ray trace the board, the front always renders “brighter” than the back. This was the also the case in v4.7. Is there a reason for this front/back difference?


#2

Does it have copper pour? The copper layer shines through the solder mask. Can you paste screenshots here?


#3

@eelik, the board has copper pours on both sides of the board.

Notice how dark the bottom is.


#4

Looks like a bug to me, then. First you must give more information - copy the version info from Help->About dialog. Graphics hardware/driver could also be important. Also the 3d viewer settings and how you made the screenshot pictures - Export current view as…? Does it look identical in the screen and in the screenshot?

It’s OK to ask here first if you’re unsure, but finally you should report bugs in https://bugs.launchpad.net/kicad.


#5

You should deselect floor on 3d viewer… I don’t have access to a PC ATM so I cannot point to the exact menu


#6

@maui, deselecting “Add Floor” in preferences for Ray Tracing did the job! Now I need to read up on what adding floor does. Thanks!


#7

It adds a floor plane to the bottom of the board so it will look like to be placed somewhere: You will see shadows and reflection ( if enabled ) in that floor ( if enabled ). Only bottom floor is implemented currently.

EDIT: Btw, it looks dark with floor enabled because the floor is blocking the light that comes from the back direction.