3D View Render Quality - Windows vs Linux?


#1

Yesterday I changed the OS of my workstation from Arch Linux to Windows 10. I had KiCAD version 4.0.7 under Arch, and the same version under Windows. Hardware is exactly the same (except for the disk drive). GPU is integrated with the CPU (Intel i5-6500 / HD Graphics 530).

One thing I noticed: the 3D view under Linux was much “smoother”. By that I mean the render quality under Linux was almost spooky in its realism. Under Windows, it’s as though it’s being rendered for a lower-resolution display: the gradients are more evident, straight lines look jagged. Even the fonts on the silkscreen are (were) more readable under Linux. To me, it reminds me of whether or not anti-aliasing is enabled for fonts.

A couple screenshots:

Image 2 - Linux
Image 2 - Windows

It’s not a dramatic difference, but it’s there. Look at the white silkscreen component outlines, or white silkscreen text. It’s particularly noticeable on the pin headers on Image 2.

I played with the 3D viewer options in KiCAD, but was unable to affect the smoothness.

I suspect this is a system-level issue, but I don’t know where to look to experiment with different settings.

Any thoughts?

Thanks!


#2

Here are another pair of images (was only allowed to post two in the first post):

Image 1 - Linux
Image 1 - Windows


#3

Seems like the Anti-aliasing is disabled under Windows. You can try to play with windows display drivers settings.


#4

On Windows, some drivers allow to force (low or high quality) settings for applications.
It is just an Anti-aliasing issue.
If the driver is forcing to use some settings, KiCad cannot override it.
Make sure you are using the proper driver on Windows and that you set it to “application choice” options or you can force to hi-quality settings.

In the end, lets say, it could be some issue with that driver/settings and KiCad that is not get success setting that anti-aliasing options…

Also, I suggest you try the latest KiCad nightly builds to get an improved 3D Viewer.


#5

With 4.0.7 I had to enable AA via my graphics settings (but I’m on Nvidia). Don’t know the settings panel for the Intel, though.


#6

Thank you for the feedback. I figured it was more of a system- or driver-level thing. I’ve played around with the Intel Graphics tool, but it feels pretty “dumbed down” to me—there doesn’t seem to be too much that can be configured. Unless I’m missing something, which is entirely possible!

I’ll probably take this question over to Intel’s hardware support forums, as I have another (unrelated) issue anyway.

Thanks again!


#7

I don’t remember, but it may be possible that new 3D Viewer (get it on the KiCad nightly builds) are doing something different on initialization, it would be nice if you could compare the two versions…