3d view and component footprints


#1

Can anyone advise? my Kicad on mint version 5.0.0 updated, and since if I attempt to get any footprint from the library I get the following message;
‘Errors were encountered loading footprints:
Footprint library path “/usr/share/kicad/modules/Choke_Toroid_ThroughHole.pretty” does not exist’ but it does i can go to the path and all the .pretty files are there why is the program finding a problem? I can no longer use on mint, I have to load windows to use which I hate


#2

5.0.0 hasn’t been released yet so you have to be using nightly builds or compiled yourself. Please give more information of the version and installation procedure. Has it worked before, and if so, which version? Have you installed the pre-v5-libraries, and if so, how and where? What does your fp-lib-table say?


#3

I have V5 on Windows10. I don’t know how much of what I’m about to say is applicable to Mint. I hope the OP can gain some insight from what I found successful.

For my install I deleted all of V4.0.7
I downloaded the V5 libraries and copied them into in a directory I created. It was specifically NOT where Kicad would install them.

I installed V5 RCxxx.

I deleted any environment variables (if any)

Pointed Kicad to the libraries I installed.

From the librararies I copied sym-lib-table and fb-lib-table to the location Kicad would look for them. In windows this was C:\Users\john\AppData\Roaming\kicad

Rebooted and all was good.

Note I might have missed a step here but I think I listed them all.

Hope it helps with Mint.


#4

Is it possible that the .pretty directory is empty? Could it be that your user has no read access?
Are you sure the directory exists in the exact same name? (Linux is case sensitive)

Also this is a very old deprecated kicad 4.x lib. It has been replaced (during kicad 4 lifecycle) by inductors_tht


#5

thanks I will give it a try


#6

Hi, yes the initial 4.0.7 worked fine, I loaded latest from Git hub and that’s when all problems started, I have since deleted/un-installed all and reloaded the original but I still get the footprint error, to be honest because of the urgency I will have to make my design via windows but need to sort this for the long term, sorry not sure what fp-lib-table is or where to find it just thought if all is deleted and installed from scratch it should work but it doesn’t


#7

the directory is full of all symbols and is all correct case and spelling, I have even uninstalled and deleted everything and started from scratch but can’t get any symbols


#8

If you download the git repository of the latest component libraries there should be the file called fp-lib-table in the footprint library directory. You can copy it to ~/.config/kicad/. Then kicad finds the correct existing footprints. They are seen in Footprint Libraries dialog in Global Libraries, where you can also see “File: /home/john155orwhatever/.config/kicad/fp/lib/table”. In the bottom the variable KISYSMOD should point to your downloaded footprint library directory. If that points to wrong place you can change it by changing KISYSMOD variable in Preferences->Configure Paths or as an environment variable (see my draft document https://docs.google.com/document/d/1Rq8i2Ay7qpGpffaj-AQmE-Xp88ikHhgyt0Ygpi8717o/edit?usp=sharing for the latter option).


#9

Thank you, I think the problem is more basic, I just noticed I can’t delete the Kicad folder (to reinstall from scratch) I can’t set the permissions in the user folder or kicad sub directory to allow deletion I will investigate this first and see where I am as all worked fine on original install. I want to get back to that stage to understand whats going wrong incase i get even bigger problems with other software. Thanks for all your help


#10

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.