3D shape position moved between update from 5.1.0 to 5.1.2

Oh gosh… here they are…

Why are they away from board? :thinking:

Because you defined a board outline somewhere…

Uhmm… they only change I made today is assigning a PTH header to the back side, while it was on front, but in Pcbnew that operated correctly… But now you make me suspect of this operation as well :thinking:

That didn’t change, I just reloaded that board and flipped the header, in Pcbnew the outline is still proper

Hm… I just noticed you’re using a non-descriptive 3D model file name…
Let me guess, its source is the website of the vendor?

OK, you got some work to do…
KiCAD expects the 3D shape center/bottom to be at 0,0,0
Your model (and most on the net from manufacturers) are somewhere else.
You have to adjust the 3D shape placement coordinates in the 3D settings for the footprint until the 3D shape is above the footprint.
@maui has some workbench tools that work in FreeCAD to help with that I think.

Forget that.

The 3D shape is sitting above the footprint in the 3D view… so that’s not the problem.

Can you make a screenshot of the layout in PCBnew?

1 Like

Yes, STEP file is from Molex, footprint by me: I aligned them (and that worked for a few revisions, till yesterday…)


I made a new topic as this looks like a bug of sorts…

This is a so huge weirdness that can only be due to an itty bitty thingy :grinning:
I’m going to move the project on a laptop where I still have v. 5.1.0 and double check…

Done: the aspect is the same, so something kicked all the parts and traces off board (or the counter)

Do you have de edge-cuts layer enabled in pcbnew?

That’s it! I had older Edge.Cuts not corresponding to margins!
That happened when I changed output “page size”, and re-centered everything, but edge cuts
Thanks :sweat_smile:

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.