3D shape not showing up


#1

Using KiCAD 5.0.1 on Windows 10. I have a step file with the 3D shape I want.

I also have an SMD footprint that I created. In the footprint editor, I went to Footprint Properties, the 3D Settings tab, removed all 3D shapes, and added the step file. In the add dialog, the shape looks okay. But after I added it, the preview still shows the original default SMD footprint.

Still in the footprint editor, when I View > 3D Viewer, it just shows the default SMD footprint, and not my shape.

How do I get KiCAD to use my shape instead of the default?


#2

Could you give a screenshot of the Footprint Properties / 3D tab after you have added the shape file?


#3

It looks for me that everything works well.
Footprint and 3D shapes are two separate sources of information about part. Changing 3D don’t change footprint and changing footprint don’t change 3D view.
It is your responsibility to define footprint and 3D compatible to each other.


#4

It seems like you’re saying that the footprint for a part and the 3D shape for a part are completely independent. If so, then why is there a 3D shape tab in the properties for a footprint?


#6

Here’s the screenshot:


#7

Here it is when I’m adding the shape:


#8

@Robert_Baruch It appears you have some sort of Path issue going on; possibly caused by Windoze 10.

$KISYS3DMOD may not be pointing to the same path

ON EDIT: I misunderstood the content in the screen grabs.


#9

When you open Configure Paths, what does it show for KISYS3DMOD?


#10

If they where completelly independent I would not say:

I’m used to use PCB software where there are no 3D shapes. And even I have no 3D shapes there I use the name ‘footprint’ for my definition of everything what have to be done with PCB (by PCB manufacturer) to make a place for element.
Now, looking around in KiCad, I see that except my ‘footprint’ when I will be using KiCad I will also have 3D shape of element. I understand 3D as something additional to the footprint but not the footprint itself.
But if you understand 3D as part of footprint or (like me) as something additional to it the only logical place to put 3D specification is the footprint parameter setting dialog box so the place that settings where inserted in software can’t decide if 3D is part of footprint or only something directly connected with it.
In your first post you said :

I understood it that 3D looks OK but footprint not.
English is not my natural language and may be I missunderstood you.


#11

Here are all the paths. They seem correct to me.

Just for fun, I also copied the wrl file to F:/ just to see if it was a space-in-the-path problem, but same issue.


#12

In the Footprint Properties/3D Settings tab, the small 3D image of the Footprint can be rotated in the viewer.

Is it possible that the 3D location dimensions have placed it on the back side of the board?

ON EDIT: Was trying to make a short reply during a commercial break of the football game.


#13

No, I did rotate the 3D image in the viewer, and there’s no sign of my 3D shape. Here’s the wrl if you want to try it: D_0805_Wide.wrl (233.9 KB)


#14

This is a strange one.

The text for the .wrl file does not match up with the other KiCad official library files.

Somehow, opening one of the official KiCad files first, then allows this file to be viewed in the “Select 3D Model” window; without it actually making it visible in the FootPrint viewer. This 3D model also fails to incorporate into the PcbNew 3D board viewer.

This issue is above my pay grade to offer a solution.

At this time I did not think to see if the model showed up in the


#15

What tools have been used to create this 3d model?


#16

I can confirm @Sprig findings - it opens in the ‘select model’ window but not in the 3d footprint viewer. Attempting to open this file in Blender leads to an error.

It looks like there is something rather odd about this model - as @Rene_Poschl is suggesting. Where did it come from?

Is it, perhaps a VRML 1.0 model? I think that only VRML 2.0 models are recognised in KiCad.


#17

I downloaded the step model from here, and then converted it to a wrl using FreeCAD.


#18

If you already use freecad then i would suggest the use of the stepup extension to generate the proper wrl files.


#19

If you import the model and footprint into Freecad you will see that they are not aligned; the origins are shown in the screenshot.

If you adjust the alignment of the model with the footprint and then use @maui KSU tools, you can export both the wrl and step models.


#20

Thanks, that was the problem! Sorry, I’m not new to KiCAD but new to the 3D model aspect of it. I used the stepup tool in FreeCAD and it worked very well!