3D not visible in v5 rc2


#1

In v5 rc2 I don’t see 3D shapes. When I try to see 3D from Cvpcb I see only pcb, holes and pads. Same in PCBnew.
In /usr/share/kicad/modules/packages3d/ there are 54 folders containing many files.
In PCBnew, menù Preferences → Add 3D shapes … → window [Add 3D shapes Libraries wizard] 3D shape local folder is “/usr/share/kicad/modules/packages3d/” and I get an error message:”It is not possible to write in the selected directory. Please choose another one”.
I checked permissions of “packages3d” folder that seems the same of “modules” folder.

KiCad v5 is installed in LinuxMint 18.2 64 bit, here’s version infos:
Application: kicad
Version: 5.0.0-rc2-dev-unknown-d09445c~65~ubuntu16.04.1, release build
Libraries:
wxWidgets 3.0.2
libcurl/7.47.0 OpenSSL/1.0.2g zlib/1.2.8 libidn/1.32 librtmp/2.3
Platform: Linux 4.4.0-53-generic x86_64, 64 bit, Little endian, wxGTK
Build Info:
wxWidgets: 3.0.2 (wchar_t,wx containers,compatible with 2.8) GTK+ 2.24
Boost: 1.58.0
OpenCASCADE Community Edition: 6.8.0
Curl: 7.47.0
Compiler: GCC 5.4.0 with C++ ABI 1009

Build settings:
USE_WX_GRAPHICS_CONTEXT=OFF
USE_WX_OVERLAY=OFF
KICAD_SCRIPTING=ON
KICAD_SCRIPTING_MODULES=ON
KICAD_SCRIPTING_WXPYTHON=OFF
KICAD_SCRIPTING_ACTION_MENU=ON
BUILD_GITHUB_PLUGIN=ON
KICAD_USE_OCE=ON
KICAD_USE_OCC=OFF
KICAD_SPICE=ON


#2

This means your user account (of the operating system) has no write access to this location. As this is a system directory you would need root privilege to write to it.

It is not suggested that the users should write to these locations.
I would suggest you put your libs somewhere in your user folder and setup the path variables in kicad to point there. (kicad main window->preferences->configure paths)


In addition, the 3d shapes downloader might not be the best option to get the files aligned to the footprints. I would suggest you manually download all lib types from http://kicad-pcb.org/libraries/download/
That way you have control over what version of the libs you get.


I furthermore assume you had either an older version of kicad nightly in the past or even a stable 4.0.x release installed. If this is the case then you more then likely still have the old kicad 4 footprint libs in the fp-lib-table. Installing any kicad version will never update your personal fp-lib-table! Have a look at this FAQ entry to learn how you need to setup kicad How can i install a specific version of the footprint library?


#3

That’s clear to me.

In 4.0.7 the permission are the same but I haven’t error messages. Then it seems not necessary to write in these folders.

Done but I get one more error message:
“Directory ‘/home/giorgio/.cache/kicad/3d’ couldn’t be created (error 13: Permesso negato)”. Note that /home/giorgio/ is my home directory where I should have writing permission.


#4

Doesn’t mean you do. :wink:

hermit@~:ls -l /home/hermit/.cache |grep kicad
drwxr-xr-x 3 hermit hermit 4096 Oct 4 2017 kicad

hermit@~:ls -l /home/hermit/.cache/kicad/
total 4
drwxr-xr-x 2 hermit hermit 4096 Apr 26 11:11 3d


#5

In general I agree with you.
In particular no, here’s why:
1)in folder /home/giorgio/.cache/ I have writing permission
2) folder /home/giorgio/.cache/kicad/ has been created by KiCad with different permission that prevent KiCad itself to write in.

In my opinion this is a KiCad bug.