3D models only visible in "footprint properties..."

Hi All, I’ve been using KiCad for a long time but this is my first project in V7.07. I’m running it on Windoze 10.
I’m having trouble with 3D models. When I first began the PCB all the footprints from KiCad libraries showed their 3D models in the viewer. I added STEP models to two of my own footprints but they are not visible in either the footprint editor or 3D viewer but they are in the “footprint properties…” dialog. On top of that, at least one of the 3D models of footprints from the KiCad library no longer shows up in either the viewer or footprint editor.
I’ve closed everything and restarted but that didn’t help. Any suggestions will be welcome.
The screenshot below is of one of the components that initially displayed correctly but now does not.


Try …
From PCB Editor, select your problem component, press “E” for the device properties.
In the 3D tab re enter the path and step file.

I’ve seen this before and never took the time to understand why the 3D didn’t come along with the footprint.

1 Like

Thank you John, I tried that but still no joy. I should have made it clear that the screenshot is of one of the components that originally displayed correctly in the 3D viewer and later did not.

Try to see 3d settings if you have some THT or SMD checked to be hidden.
Or try in 3d viewer the shortcut T or S.

1 Like

Brilliant Maui! Yes, the T shortcut in 3D viewer fixed it. I didn’t know about that setting. I must have inadvertently done something at some point.