3D models missing KiCad 6

Hi @Drexter this is a known 3D bug on some specific AMD GPUs.

It was fixed last month and should only be available on the next stable releases of KiCad 6.0.5

If you don’t want to wait, there are the nighbuilds of kicad that you may want have a try.

1 Like

I will give it a go once I get to the pc. Thanks.


That’s great news. So I will just wait. Thanks a lot.

it should available also on stable-testing (aligned to stable but with latest improvements)


The legacy graphics option just changes the 2D schematic/board editor canvas. The 3D viewer will still use openGL when raytracing is disabled.

6.0.5 was released, could you give it a try?

Even if it is not on release notes (missing?), can you test if it was fixed?


Hey @kammutierspule

I can (happily) confirm it works like a charm now. PCB shows in the 3D viewer without any problem.

Thank you


Identical issue, but I’m on a mac, (non-M1). No components show up, even imported some fresh one’s followed the instructions to the letter.
Any advice is appreciated.
edit: File type I tried to import is a .step file

Not an identical issue if you can see the board. OP in this thread had problems displaying the board itself, never mind the models for the components placed on the board :slight_smile: See their screenshot 3D models missing KiCad 6 - #5 by Drexter

Your issue sounds more like a paths issue, possibly. Let’s help you in your original thread and keep this one focused on the driver issue here.

maybe this will help someone. Similar issue I sorta solved by accident. no idea if it will work for others… No 3D models at all on Mac, only green flat pads - #15 by Al_J

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.