3D Models - Issue

I’m a new user & installed kicad today.
Version: (5.1.10)-1, release build

My 3d models not working. Only footprints shows. How to solve this issue?


Are you sure?
Not all footprints has 3D models.

This is a 3mm LED. It shows only footprints. All other components same.

In KiCad there are a lot of links to 3D files which do not actually exist. The Idea is that 3D models can be added easily without modifying the footprint libraries themselves.
So I had a look at (hopefully the same) but maybe just similar footprint:

Comparing the name of the 3D models however, they are not the same.
Your’s on top, mine below:


The plural form of the library name is a strong indication that you are using libraries made for KiCad V4.

1 Like

Many thanks. It worked.

I deleted the libraries as you mentioned and added manually. It worked nicely.
By the way I downloaded the latest “KiCad 5.1.10” & it has set paths for old libraries.

Thanks for the support.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.