3D Models do not show anymore

Hi all,
a few days ago the 3D-viewer showed the 3d-models as expected.
Today I recognized they miss. I updated to V6.0.1 fom 6.0.0, but I’m unshure if 3D dissapeared right after the udate.
All my projects are updated from V5 to V6.0.0.
When I edit a FP and go to “edit FP” I can see the path is faulty:

That apllies to all FP in every project, as far as I can see.
I dont know much about PC stuff, a PC to me is an still underdeveloped tool that needs to much attention.
So I kindly ask for some hint how to fix that.
Thanks in advance!

You have v5 footprints in the project. The 3D model path is embedded in the footprint. It includes the ${KISYS3DMOD} variable which is legacy from v5.

EDIT: You can define that variable in Preferences → Configure Paths. Give it the same path than KICAD6_3DMODEL_DIR. The 3D libraries are (mostly?) compatible, so you have a good chance of getting several or most of the models back. This of course depends on your design.

2nd EDIT: You can also download the old 3D library, save it somewhere and point the variable there.

@eelik ok, got it that far, thanks a lot.
I found out, that “update FP from lib” replaces the FP, and thus the replaced FP points to the V6 3D model path.
If I update all FP from lib, I get rid of the ancient V5 pathes, but might risk changes in FP.
What do you think?

Another, more risky way is to update the footprints from libraries. Because the footprint name (in the form Library:Footprint) is the same in v5 and v6, in standard setup KiCad 6 can usually update the old v5 footprint to v6 footprint. At the same time the 3D model path is updated if you choose it to do so.


EDIT: you asked while I was writing. :slight_smile:

we crossed the very second, thank’s!

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.