3D model not rendered

The following 3D models don’t render in the footprint editor (V5.1.8):

https://www.molex.com/pdm_docs/igs/503398-1892_igs.zip

https://www.molex.com/pdm_docs/stp/503398-1892_stp.zip

They render both fine in Freecad.

If, in the footprint editor, I point to another IGS or STEP file in the same directory, it renders it correctly.

Are there different versions out there of both IGS and STEP that render fine in Freecad but not in Kicad?

If it opens in FreeCAD, have you try to export them using StepUp and trying to use the exported models ?

EDIT: I just tested what I suggested and works well :slight_smile:

1 Like

This works well for sure, I did this to mine as well.

It’s because the model has a big offset from the origin. You can see it via double clicking “Solid” component under the part in FreeCAD.

You have options like moving closer the model to origin in FreeCAD, enter offset values in model view or exporting with StepUp like @der.ule suggested.

I tried to install Stepup in Freecad without success.
If I try via Tools -> Addon Manager, it tries to download a list of workbenches/macro’s that never finishes. Same problem at work and at home. Internet connection is fine.

image

image

My Freecad version is:
OS: openSUSE Leap 15.2
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.18.Unknown
Build type: Release
Python version: 3.6.10
Qt version: 5.12.7
Coin version: 3.1.3
OCC version: 7.3.0
Locale: English/United States (en_US)

I tried also to install Stepup manually by cloning the Stepup repo and copying it into /usr/share/FreeCAD/Mod/ as described here


Then I restarted Freecad but nothing has been added, I can’t find Stepup in Freecad.

In FreeCAD under View->Panels check the “Report view” to get the debug panel below

I get the following error in the “Report view”

GitPython not installed! Cannot retrieve macros from git
Unable to fetch the code of this macro.Traceback (most recent call last):
  File "D:\Data\Downloads\FreeCAD-0.18.4.980bf90-WIN-x64-portable\conda-0.18.4\Mod\AddonManager\addonmanager_macro.py", line 147, in fill_details_from_wiki
    code = code.replace(b'\xc2\xa0'.decode("utf-8"), ' ')
AttributeError: 'list' object has no attribute 'replace'

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
  File "D:\Data\Downloads\FreeCAD-0.18.4.980bf90-WIN-x64-portable\conda-0.18.4\Mod\AddonManager\AddonManager.py", line 852, in run
    self.macro.fill_details_from_wiki(url)
  File "D:\Data\Downloads\FreeCAD-0.18.4.980bf90-WIN-x64-portable\conda-0.18.4\Mod\AddonManager\addonmanager_macro.py", line 149, in fill_details_from_wiki
    FreeCAD.Console.PrintWarning(translate("AddonsInstaller", "Unable to clean macro code: ") + code + '\n')
TypeError: must be str, not list

This is of course “interesting” because I’ve been using this version and the addOnManager for a while without problems, it may be a temporary outage.

Thank you everybody for trying to help.
I managed to install Stepup in Freecad.
I made the error to install it in /usr/share/FreeCAD/Mod/.
After I did a

mkdir ~/.FreeCAD/Mod
cd ~/.FreeCAD/Mod
git clone --depth 1 https://github.com/easyw/kicadStepUpMod.git

it worked.

I opened the model in Freecad, activated Stepup, and opened the Kicad footprint.
Now I was able to see in Freecad both the 3D model and the footprint/pcb.
It was also obvious now that there’s a big offset between the two of them.

Now I have to learn how to move the model near the pcb/footprint.
If, in the meantime, somebody wants to explain it here in “for dummies” style,
I would be gratefull. I’m a complete noob with Freecad.

Thanks anyway for pointing me in the right direction.

I am no expert on FreeCAD, but StepUp makes it very easy to move the models, because it has a very handy tool bar.

If you don’t see the tool bar click on this icon:
image

you will get the StepUp Toolbar:

then you click on our model to select it:
image

and click on the different icons to rotate it and move it.

it has also nice documentation if you click on ksu Tools->Demo
image

I recommend you to take a look at the last 3 pdf for (much) more information.

I managed to do it! :grin:

I simply measured the distance between the two objects in Freecad and corrected it in KiCad footprinteditor:

For sure it will not win the beauty contest but at least I can continue now.
I already lost too much time with it.

Thanks again everybody!

Glad that it worked out at the end!

However there is a drawback with the way you solve it, next time you want to use the model you will need to center it again, if you make all the alignments in FreeCAD and then export it, it will always appear where it should be

1 Like