3d Model Import But Not Getting Visualized?

Just a question about bringing in a 3D model of a temperature sensor:

I can make the model in SolidWorks and save it in .wrl format. Then I open my sensor in PCBnew and go into module editor, and into 3D settings, and browse for the .wrl file. I select it, but it doesn’t show up when I open either the part in the 3D viewer or in the whole pcb. Any ideas?

File is attached to the module:

But doesn’t show up in 3d view:

I’m a total KiCad noob and I’m just learning about how to make library parts with 3D models, but maybe my experience from earlier today will be helpful.

I use Cobalt from Ashlar for 3D modeling. When I export my model to .WRL format, Cobalt prompts me to select VRML version 1.0 or 2.0. I tried 2.0 first, and my model didn’t appear in the 3D view of the footprint editor. Then I tried version 1.0, and it rendered properly.

I’m not familiar with SolidWorks, but maybe it also allows you to export in different VRML format versions?


Thanks for the advice. In Solidworks, I had two options, VRML 1.0 or VRML 97. For some reason the 97 version works. I then also have to scale everything by 0.3937 (as described in this post)