3D model display issue KiCad 7.x

I have an issue to display 3D for all components and PCB board.
Setup :

  • Kicad 7.0.8
  • Debian 11

What is working :

  • All links are corrects (global links and local)
  • I am able to open on freecad 3D models
  • all component 3D view are enable (on the toggle tool bar)
  • when export the complete board in step, I am able to see the 3D components on a third part software

What is does not work :

  • 3D view in footprint view
  • I see only the board into footprint view and PCB editor
  • impossible to see 3D model in .stp or .step or .wrl format

Others screenshots

Seems like the footprint was carried over from v6? May check under Preferences → Configure Paths if KICAD6_3DMODEL_DIR is defined and points to the directory the 3D models are located in. It probably should be the same path as KICAD7_3DMODEL_DIR

That footprint looks wrong for that component . . .

I had already done this to keep the link :

And when I export the PCB into step, I have all 3D component mounted

Kicad 7 was installed without previous version on this computer.

good catch, but it’s only an example with this resistor. It is all the same issue will all component that has a linked 3D.

1 Like

I think I found the error: The 3D render seems not be able to render STEP files anymore, only WRLs. I would consider this a bug worth reporting on gitlab if it was not done alredy.

Unfortunately, WRL, doesn’t work either :frowning:
I tried with all format that are declared functioning on the Kicad Doc.

hmm, have you tried changing the 3d renderers setting, e.g. disable anti-aliasing? I remember that there were some issues with some settings on certain hardware in the past.

It changes nothing.

Screenshot from 2023-11-14 14-03-20

I tried with multiple configurations and default, without succes.

Both STEP and WRL work fine for me in 7.0.9.

The KICAD6 vs. KICAD7 variable is not the problem (I don’t know what is), but for the information of you and others, you do not need the duplicate KICAD6_3DMODEL_DIR variable.

When V7 sees the KICAD6_3DMODEL_DIR variable in a footprint, it automatically interprets it as KICAD7_3DMODEL_DIR, unless you’ve manually defined a KICAD6_3DMODEL_DIR variable yourself. So by having your own copy of the KICAD6 variable, you’ve disabled this automatic feature, but the result should be the same since you’ve defined the KICAD6 variable to the same thing yourself.

not for me, 7.0.9-ubuntu20.04.1

Two days ago I updated from v7.0.8 to v7.0.9.

When adding a footprint to a PCB, all of the Paths showed correctly and all of the Folders were listed. But, No Footprints were listed when clicking the Drop-Down Arrow. Same was true for the Symbols.

After checking everything and determining everything was correct (by comparison of Screenshots from my Previous Update wherein the same thing happened), I read my Notes to myself…

The Notes said, simply Re-Link the paths. BINGO!

All of the Paths show to be the same as before but, now All is back to working order after re-linking… Additional Clue (to me) was after Update, my personal Plugins were no longer in the Folder… The Folder was replaced and - I simply put them back into the new folder.

I do the update (from 7.0.8) to the 7.0.9 and keep you in touch.

I had to do so, the 7.0.8 does not have this feature

Finally, since I’m working on Debian 11, it require packets from Debian12, it is working well on a flatpak env.
Same as Black coffee, I had to update path and put back plugin into the folder.

have a nice day all! :slight_smile:


I assure you it does