3D footprint only showing in component footprint


#1

Hello all,

I just started using KiCAD, as well as Wings3D and FreeCAD with which I designed a custom 3D model for a 10 LEDs bar component. These are fantastic tools!

Everything went well until I realized that the 3D model assigned to the 2D footprint was only showing in the 3D viewer from the footprint editor, but NOT showing in the 3D viewer of PCBnew (v4.0.7), as shown by the images:

(top: 3D view in footprint editor, bottom: 3D view in PCBnew)

Can someone explain to me what I’m doing wrong?

Thanks. G13


#2

update the footprint in the layout… I bet you created the 3d model after you did your layout.
the footprint in the layout is a carbon copy of the one in the lib, placed in the .kicad_pcb file at the time of loading the netlist (or last manual update).
the 3d shape info (or any other changes to the library footprint) doesn’t automatically travel downstream - to not destroy your layout via changes in the library.

PS: try to get your mojo working with freecad and create STEP files instead of VRML in wings3d, the later workflow has become obsolete within the last 6-12 months.

PPS: nice job


#3

Hey Joan,

thanks a lot for your reply and solution, it worked! I certainly wouldn’t have figured it out myself :smiley:

Okay, thanks for the the tip…

Thanks!

By the way, this board is a NON-rechargeable battery charger. I found on a website an internal document from a famous battery cell manufacturer stating that common non-rechargeable alcaline batteries can actually be recharged about 10 times, provided the voltage is not below ~1.2V, and that the recharging current is regulated to say 100mA. I’ve successfully tested it with AA, AAA and LR44 cells.

Cheers. Gorgo Treize.


#4

Slightly off topic but I flew 3000 miles to look at a piece of ‘faulty’ equipment suffering from a less than expected rechargable battery life, to find that the on site maintenance person had fitted dry cells instead of nicads.
I was amazed the thing worked at all.


#5

hehe :stuck_out_tongue:

About the main topic, for those new users reading this post, the “update footprint” in layout is done by selecting your footprint on the PCB (click on it), press “e” key, and click on “Change footprint” (or something… my interface is in french, reading “Changer empreinte”), and then click “apply” with the defaut options.

G13


#6

The default option only updates the current footprint. (by reference)
There are other useful options.
You can change all footprints of the same type. (updates all footprints with the same footprint name)
There is the option to update all footprints of the board.
And for some reason one can also update all footprints that have the same value.