3D export not locating the assigned step file

I’ve search and searched and not come up with a solution.

I have some step files attached to footprints that correctly display on the kicad 3D viewer, there are no .wrl files in sight anywhere. Yet when I export the exporter says no model found and it is missing.

The main example is U19 which is the big SARA module

I’ve tried changing the filename from .STEP to .step with no change.
The paths include my 3Dmodels folder the kicad is using…




Kicad version :
Application: Pcbnew
Version: (5.1.10-1-10_14), release build
Libraries:
wxWidgets 3.0.4
libcurl/7.64.1 SecureTransport (LibreSSL/2.8.3) zlib/1.2.11 nghttp2/1.39.2
Platform: macOS Catalina Version 10.15.7 (Build 19H1011), 64 bit, Little endian, wxMac
Build Info:
wxWidgets: 3.0.4 (wchar_t,STL containers,compatible with 2.8)
Boost: 1.75.0
OpenCASCADE Technology: 7.5.1
Curl: 7.54.0
Compiler: Clang 10.0.1 with C++ ABI 1002

Build settings:
USE_WX_GRAPHICS_CONTEXT=ON
USE_WX_OVERLAY=ON
KICAD_SCRIPTING=ON
KICAD_SCRIPTING_MODULES=ON
KICAD_SCRIPTING_PYTHON3=OFF
KICAD_SCRIPTING_WXPYTHON=ON
KICAD_SCRIPTING_WXPYTHON_PHOENIX=OFF
KICAD_SCRIPTING_ACTION_MENU=ON
BUILD_GITHUB_PLUGIN=ON
KICAD_USE_OCE=OFF
KICAD_USE_OCC=ON
KICAD_SPICE=ON

Any thoughts?

This does seem to occur for a large number of models i’ve manually assigned but not all.

Out of interest, i’ve opened the project using latest kicad nightly aka V6.

Opening in 3D viewer all is correct. Exporting step files give an error about scaled objects (there are just 2) which is fine… low and behold all my manually added .step files are there… and there are lots of complaints about .wrl files. So kicad V6 works for all my models but none of the native ones where .wrl is the default.


This is the fusion 360 opening the step file from V6… which has all of the step files missing from V5 and non of the native ones where there is a .wrl file in 3D settings… so V6 doesn’t ‘find’ or ‘use’ the step version instead…