3D components too big


#1

I noticed that the 3D view of a lot of the radial caps are too big on my system
Almost half of the components don’t line up with the holes in the pcb.
Is this a known issue?
Is there a (temporary) workaround?

I’m currentl using KiCad 4.0.6-e0-6349~53~ubuntu14.04.1.release build


#2

I updated the footprints and 3d models like a week ago.
a workaround would be to change the scale to 0.39371.
but the correct way would be to update you 3D models (PCBNew has an option for that under Preferences)


#3

The correct thing to do would be to download the current 3d models from either the kicad-library repo or from the packages-3d repo
(In nightly builds there is even a 3d shapes downloader.)


#4

Ok,
Tanks a lot for fixing the lib and pointing out to me that it’s fixed.
Updated the lib and it works now.


#5

Update:
Getting the 3D models to look right was quite a struggle and I’m stil not completely there.
I’ve been klicking a lot in circles with my mouse and I finally gave in by giving KiCad sudo rights to write to /usr/share/kicad/.
Only now the light brighens and I realized I could have temporarily changed the owner of /usr/shar/kicad/
(PS: What’s the recommended way to solve this neatly?).

But KiCad did it’s thing and I had working Elco’s.
Unfortunately this also resulted in a lot of other caps being too small.
This was easily fixed by ditching the whole Capacitor_ThroughHole lib and only using the Capacitor_THT.

Today I thought to just get all the 3D libs from Github (maybe I should just clone) but I did it with KiCad/PcbNew.
After about 10 minutes (It’s a 1GB download) the download stopped with the following error:

Error fetching JSON data from URL ‘https://raw.githubusercontent.com/KiCad/kicad-library/master/modules/packages3d/Connectors_JST.3dshapes/JST_PH_S10B-PH-K_10x2.00mm_Angled.wrl’.
Reason: ‘IO_ERROR: curl_easy_perform()=7: Couldn’t connect to server
from /build/kicad-I8aRie/kicad-4.0.6+e0/kicad/common/kicad_curl/kicad_curl_easy.cpp : Perform() : line 92’


#6

to download a sub-part of the 3D library you can use
DownGit
DownGit


#7

I would put the libs somewhere in the home directory and change KISYS3DMOD to point to this location. (Kicad main window->preferences->configure paths)