3D Component PCB background color issue

Hello,

I am facing issue of change in pcb surround color, when creating and attaching 3D model using FreeCAD with KiCadStepUp work bench. Attaching to custom footprint created in KiCAD Foot print editor

  1. Created a custom footprint in KiCAD for Cypress BlueTooth module

  2. In FreeCAD created a 3D model of the module

  3. Using KiCadStepUp work bench, imported the foot print .mod file in FreeCAD
    (I can see PCB surround area color is changed from PCB green to a Gray shade)

  4. Made a compound object of Footprint and 3D model

  5. Export back to KiCAD as step and wrml format
    (Without modifying color as well as changing footprint PCB surround area color to PCB green)

When we look at 3D rendering of PCB layout, this 3D model’s surround area remains different.

This issue was not faced previously.

Attaching .pretty folder containing .mod file
As well as FreeCAD project folder and generated step file.

Any pointer / guide line to solve this issue will be appreciated.

Best Regards,
Viany

MyCYBT-343026-01.pretty.zip (1.0 KB) CAD_BT-module_CYBT-343026.zip (353.3 KB)

I am on Windows 10
---------------------------Version info ------------------
Application: KiCad
Version: (5.1.4)-1, release build
Libraries:
wxWidgets 3.0.4
libcurl/7.61.1 OpenSSL/1.1.1 (WinSSL) zlib/1.2.11 brotli/1.0.6 libidn2/2.0.5 libpsl/0.20.2 (+libidn2/2.0.5) nghttp2/1.34.0
Platform: Windows 8 (build 9200), 64-bit edition, 64 bit, Little endian, wxMSW
Build Info:
wxWidgets: 3.0.4 (wchar_t,wx containers,compatible with 2.8)
Boost: 1.68.0
OpenCASCADE Community Edition: 6.9.1
Curl: 7.61.1
Compiler: GCC 8.2.0 with C++ ABI 1013

Build settings:
USE_WX_GRAPHICS_CONTEXT=OFF
USE_WX_OVERLAY=OFF
KICAD_SCRIPTING=ON
KICAD_SCRIPTING_MODULES=ON
KICAD_SCRIPTING_PYTHON3=OFF
KICAD_SCRIPTING_WXPYTHON=ON
KICAD_SCRIPTING_WXPYTHON_PHOENIX=OFF
KICAD_SCRIPTING_ACTION_MENU=ON
BUILD_GITHUB_PLUGIN=ON
KICAD_USE_OCE=ON
KICAD_USE_OCC=OFF
KICAD_SPICE=ON
----------------------------------------- Ver info FreeCAD ----------------------
OS: Windows 10
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.18.4 (GitTag)
Build type: Release
Branch: releases/FreeCAD-0-18
Hash: 980bf9060e28555fecd9e3462f68ca74007b70f8
Python version: 3.6.6
Qt version: 5.6.2
Coin version: 4.0.0a
OCC version: 7.3.0
Locale: English/India (en_IN)
-------------------------- Ver KiCadStepUpW ---------------------
KiCadStepUpWB.Activated(v 10.0.5)

Attaching Screen Capture from both FreeCAD and KiCAD 3D preview

See the surrounding Greyish area, which does not blend with PCB 3D view when used in a board layout.
Can not match color, by changing in FreeCAD, while exporting back as PCB color also.

You apparently have selected the “board” along with the actual component when you have exported from FreeCAD. Don’t select the footprint when you export, only the BlueTooth module 3D model.

2 Likes

Oh my…

Yes, so stupid of me. After designing 33 components this still crips up :grinning:

Thanks @eelik for quickly spotting this

solved

2 Likes