3-d part not showing from PCB layout editor

I have just started to learn KiCad, so I am doing a lot of experimenting, and errors, but I am slowly progressing.
I have run into a problem I hope someone can tell me how to solve:
I have made a custom part based on DIP 14, and I chose a footprint without a 3-D representation of the IC. I could then, off course, only see a 3-D representation of the actual footprint in 3-D view. I then found another footprint which also had the IC represented, so I tried to edit the part from the schema editor, replacing the old footprint with the new one, but I still cannot see what I want. If I place a new part, and associate with the correct footprint, then this part will show as I want it.
Do I have to delete the wrong part from the schema and then replace and associate the correct footprint (a lot of work drawing new wires) or is there another way around?

Best regards


After you change the footprint assignment in your schematic, and then update your PCB from schematic.
If the new library footprint is just update of your existing one, edit your footprint and select “Update footprint from library”.

Hello fed4u.
Thank you for answering.

I tried that before I created the topic, and this does not change anything, but the altered part will display perfect if I put a new one on the schematic.

But do you get your updated footprint reference after you update PCB from schematic?
What’s the name of your custom footprint, what’s the name of your “another footprint” and what name do you see in PCBNew’s Footprint identifier?

When I look at the properties from the Schema editor, the references are correct, but even if I update the PCB (after saving the schema, if it was changed , the old references still are used in the PCB editor. I had to look at the footprint properties from the PCB editor, and manually change the footprint, then it worked OK.

Thank you for the input - it directed me to find a solution!

All the best from


Do you perform “Update PCB from schematic”?

After you save your schematic and perform the “Updated”, your new fooprtint should be updated.
If not, post the screenshot of Kicad’s “Changes to be applied” window.
This way it works for me all the time.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.