1) How to Rename a Library? 2)How to Delete Library?

I’m running 6.99 on a Win 10 Pro PC.
I just created my first Library and first new symbol.
1 - How can I rename the Library?
2 - How to delete the Library?
3 - When I created the new Library it did not ask me “Global” or “Local” as I’ve seen in video tutorials…
How do I make it Global or just assigned to the Current Project?
3 - I’m creating a multi-unit symbol that I will need to edit often in the Project so…
How to Open the Library and edit or delete the Symbol?

I’m sure its all there right in front of me but after a long day learning Kicad my eyes are rolling back in my head :slight_smile:
Thanks for any help.

1+2) Use the windows filemanager of your choice. After renaming/deleting you should also change the setting for this library in Kicad–>Preferences–>Manage symbol libraries

3 The question-window “Global library / local library” is only displayed if you have a project open. I guess you created your library with all projects closed.
To change the library from “global” <–> “local” you have to open the project where you want the library. Than use the “Kicad–>Preferences–>Manage symbol libraries”-dialog to delete the library from the “global”-list and add it to the “local”-list

I’m creating a multi-unit symbol that I will need to edit often in the Project so…
How to Open the Library and edit or delete the Symbol?

I’m not sure if I understand the intention, but try this:

  • insert your self-designed symbol into schematic
  • doubleclick your selfdesigned symbol → symbol properties-dialog opens → click button " edit library symbol" (Don’t use “Edit symbol”!!)
  • symbol-editor opens and presents your symbol ready for your changes
  • do some changes. Save symbol/library
  • leave symbol editor open, change back to schematic editor
  • doubleclick your symbol → symbol properties dialog → click button “update from library” → select all update-fields + checkboxes → Update
  • work with the modified symbol until you are displeased again → start with step 2

Everything below is a more “blow by blow” account of @mf_ibfeew s comments just above.
It might make everything a little easier as you are so new to Kicad.

The easiest way to change your library name is to:
Use your Operating System not Kicad) to navigate to your library file/folder then just change the name of your library.

Next: Open Kicad, go to Preferences / Manage Symbol Libraries / click on the appropriate tag (Global or Specific) / Click the folder logo (between the + and the up arrow) /
This brings up a new screen called “Select Library” then navigate to your newly named library, find your new library, highlight, click Open and you will find your new library at the bottom of your list of libraries.

Don’t alter the “library path”, but if you wish, alter the “Nickname” then click OK. You will now find that newly named library AT THE BOTTOM of your list of libraries. All new libraries appear at the bottom of the library list in the Symbol Libraries list.

HINT: The nickname determines where your library will appear in the library list in your Schematic Editor, so if you place a 1 in front of the nickname it will appear right at the top of your library list.

To delete a library: Go to Preferences / Manage Symbol Libraries / Find your library either in Global or Specific (it will be at the bottom of whichever list), highlight that library line by clicking on it somewhere then click on the rubbish bin icon.
This will only remove that library from Kicad. It will not remove that library from your computer.
To remove it from your computer, first remove it from Kicad as previously explained then with your OS (not Kicad) navigate to that library, highlight and Delete.

In Schematic Editor, click “Create, Delete & Edit Symbols” icon, find your Library in the Library list, click on your library, double click on your symbol you wish to alter in your library then, using the “Unit” box up top in middle, find the part of the symbol you wish to modify and go for it! :slightly_smiling_face:

Great help from all. Thanks !

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.