Warning Copper sliver -- SOLVED

Just upgraded to 7.0.2 from 5.11… new error warning in PCB NEW…
“Warning: Copper sliver (F.Cu)”

What does it mean and how to get rid of it??

Refer to https://www.mclpcb.com/pcb-guide point 4, it is a decent description.

If you don’t want to check for slivers, you can disable the check in setup->violation severity. What is considered a sliver is hardcoded AFAIK, there is no setting you can change.

If you want to remove the cause on your PCB that can be tricky as the error markers are not always accurate.
There is an active bug report regarding slivers: https://gitlab.com/kicad/code/kicad/-/issues/14549
Generally, you might have to play around a little to avoid situations like this:

@straubm, Thank you very much. At least I now have an idea of what it is warning me of… now to see if I can eliminate it… if not then I will set it to ignore. Thanks again!!

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.