Visualisation 3D

Bonjour, depuis quelque temps, je ne visualise plus les composants en 3D sur le PBC, seul le PCB est visible. J’ai désisntallé et réinstallé la version 5.01.9 et le résultat est le même.

Dzień dobry, {Good morning,}
Fajnie, że rozumiem co piszesz :slight_smile: {It’s nice that I understand what you are writing :slight_smile: }

Hello, At the request of Piotr (whose language I do not know), I reformulated my question in English:
I no longer get the 3D view with the implanted components, only the PCB is visible. I uninstalled and reinstalled the latest version of KiCad, it’s the same.
Thank you for your reply

Unable to send a message in English, the text is automatically translated into French …

Have you actually downloaded and installed the 3D models? Also, you should be aware that some of the components do not (yet) have a 3d model associated with them. (See FAQ entry).


That suggests that previously you had 3D. May be you know what you did before trying to repair by reinstalling?

Your configuration is not uninstalled during KiCad uninstallation. Under Windows that configuration is in C:\Users\{UserName}\AppData\Roaming\kicad directory. To have clear install you should delete that directory but may be it is better to repair what you probably damaged.
I had never such problem. I would start from Footprint Editor and check if I can see there 3D models (Footprint Properties - 3D Settings tab). Models uses KISYS3DMOD directory shortcut. I have never edited it - don’t remember where it is edited - you should find it.

Not precisely. The 5.1.9 or the latest nightly?
And probably the system you use can be helpful.


Thanks for these informations.

I searched for the KISYS3DMOD directory, but it is missing from my computer.

Which is to say that the version 5.1.9 that I reinstalled does not contain this installation folder?

In this case, I would have to reinstall an older version that does contain this directory, but which one?

Also, I tried the 3D footprint editor, but again, no component is visible, only the PCB trace.

Thank you for the answer.


Start PCBnew.

Preferences | Add 3D shapes libraries wizard

Enter this into the URL field:

@Jmg54 : KISYS3DMOD isn’t a directory. It’s a kicad internal variable pointing to the directory containing the 3D packages.

First you must find the directory where the shapes are, note it. Second, open a project, go to the “preferences” menu entry, then “configure paths”. A list of all the kicad internal variables is displayed. Take a screen copy for further reference and save it. Third, make sure that the variable is pointing to the directory you found. if KISYS3DMOD isn’t listed, click on the “+” to add the path you found. Click on OK.

Now you can open your project, normally the 3D models should be there.

in addition, should you have a custom 3D models directory, you can add a custom variable with its path to the current list.

PS. in Windows, the 3D shapes directory should be in …\Kicad\share\kicad\modules\packages3d.


Thanks for this answer.

I have all tested :

  • the paths are OK (but in grey color)

  • the directory for the 3D shapes contains all the elements,

  • The soft v.5.1.9 has been installed (after desinstalling the old version)

and never 3D view…

I am very disapointed !


Good evening and thank you for this information.

All paths are OK, all directories and libraries are in their place, pointers are alike, but unfortunately I still don’t have a 3D view.

I can only visualize the PCB plate in 3D with the screen-printed imprints, but still not the components which have their 3D files well in the directory provided.

It is not very serious, but rather inexplicable.

I uninstalled, cleaned the computer and reinstalled but nothing can be done!

I don’t understand anything anymore because I had all that before.

Thank you.

Hi @Jmg54, Sorry, I didn’t notice your previous message.

Some more clues:
In the 3D View, make sure the visibility boxes are checked:

Then, in the footprint properties, Make sure that the fabrication attributes are set to Through hole and not to Virtual:

the 3D Settings tab should show like this:

Is the part showing on the window ? Are the other parameters correct (especially the scales and the offsets) ? Note that the “Preview” box (up right corner) is related only to the picture, not to the 3D View window. Under the Windows’ File Explorer, navigating to the 3D model’s path (retyping the contents of your Kisysmod variable, do you find your model ? (In my case, I have an additional variable (USER_3DMOD_DIR) I created to point to my own model production).

Since you already checked the internal variables, their paths and your library locations and if this doesn’t work, I don’t see what would happen.

@Rene_Poschl is of a great help. He probably would recommend to read his FAQs: Library management in KiCad version 5 and Where are the configuration files (settings, library tables)?
It might be a question of Library Tables. I’m not skilled at all in this matter. My last recommendation would be to ask Rene.
Anyway, please, keep us informed of your troubleshooting results. Good luck

Thank you for this valuable information.

By carefully examining the 3 screenshots you sent me, I can already say that on the first two, everything is identical with me (except for the language of course).

Excepted that the Footprint properties as 3 lines and not like you.

On the third, the only difference concerns the path of the 3D images.

But since you have created your own models, it makes sense.

I have attached a screenshot of my own 3D view window.

To conclude, I’m like you, I don’t understand why the 3D view is only possible with the small piece of PCB that contains the footprint.

Thanfs for all, but it’s a mystery…


What is KISYS3DMOD actually set to?

Go to Preferences --> Configure paths …
Screenshot 2021-04-28 at 15.18.16

And check that KISYS3DMOD is set to where your 3d models have been installed.
Screenshot 2021-04-28 at 15.18.35

  • All the symptoms are converging toward a broken path. It may be wrongly configured or absent.
    Please, post a copy of the variable page.

  • In a window, preferences, how are the directory separators labeled " / " or " \ " ?
    Normally it’s " \ " although in the “propriétés de l’empreinte” it’s " / "

only for information, my configuration is not a standard one.

  • If you copy the content of the kisys3dmod variable, appended by the 3Dmodel relative path in the search bar of the Windows explorer, do you end with your 3Dmodel ?

  • Open the 3D setting page of a part in PCBnew, click on the folder icon at the right of the “+” icon, navigate to your footprint, add it. You may have to uncheck the first 3D model to see the added one.
    Here the switch model has arbitrarily been replaced by a trimmer:

    to remove it, select it then click on the basket. Don’t forget to discard the file when closing PCBnew !

  • Back to your reply:

[quote=“Jmg54, post:13, topic:28889”]
To conclude, I’m like you, I don’t understand why the 3D view is only possible with the small piece of PCB that contains the footprint.
[/quote] Do you mean that you can see your model in this window ? If so, that would contradict the annexed picture ?

  • Does it work with .stp models instead of .wrl ones ? Please check.

On April 21th you wrote:

May you take a picture and post it ?

You are faster than lightning!

Thank you for your prompt response.

First response to your proposal to copy the content of the Kisys3dmod variable into the explorer: I point to the directory which contains the 3dshapes directories. If this is the kind of folder it is, then I imagine the path is OK.

I am sending you a screenshot of the paths.

Tonight I will do what you suggest “Open the 3D settings …”

Thanks again !

Variables d'environnement.jpg

Good evening again,

I had a few minutes, so I did the manipulation you suggest.

I got the print once again on my own.

I also checked and unchecked the two models alternately, nothing new is obtained.

I have attached a new screenshot to you.

Have a nice evening.

Thank you for this response.

I have already done all of this, but no improvement.


The path you have added here is to a footprint (.kicad_mod), not to a 3dmodel (.wrl or .step or .stp)

On my system, the path you’re looking for is: C:\Program Files\KiCad\share\kicad\modules\packages3d\Connector_Molex.3dshapes\<model filename here>

I don’t see a model with the filename you specify. I think you might be looking for Molex_KK-254_AE-6410-04A_1x04_P2.54mm_Vertical.wrl

Try this path: C:\Program Files\KiCad\share\kicad\modules\packages3d\Connector_Molex.3dshapes\Molex_KK-254_AE-6410-04A_1x04_P2.54mm_Vertical.wrl

edit: I do not have a footprint by that name, either. What version of the libraries do you have installed?

You can also try this path: C:\Program Files\KiCad\share\kicad\modules\packages3d\Connector_Molex.3dshapes\Molex_KK-6410-04_04x2.54mm_Straight.wrl

It is possible that there is no model for this footprint. Again, I do not have a footprint by that name in my libraries. You will need to check the directory I listed above to see if there is a file by that name.