User Path Configuration

Hello, I try to setup my personal path for User_kicad_footprints, User_kicad_packages-3D and User_kicad_symbols. For that I read the tutorial from Rene_Poschl. As describe on the document Kicad does not detect automatically Libraries, you have to use the new concept for V5, under Preferences Menu you will be able to setup the path (Configure Path). I do that using add button :
After that I do not see on Manage Symbol Libraries & Manage Footprint Libraries my User path :
I probably missed something or the name of the user paths is not correct, more details on this setup would be welcome! Thank you.
In complement under Windows OPSys the set variables are :
Can I need to add manually my User one ?

You don’t have to touch windows variables.
Your custom user paths will not be listed but they still work. Even more, they will be automatically inserted if you add a library from that path or subdirectory of that path.

1 Like

Thank you qu1ck, Ok that’s not cool, so it’s better to note it somewhere …
So in sequence, we must add one by one the libraries that interest us in the editor of symbol and footprint libraries that’s right ?
For 3D models how do we do it?

Yes. See Library management in KiCad version 5

3d models do not follow the library model of other assets. Footprints point directly to a file. That path can however include a path variable. See Tutorial: How to make a footprint in KiCad 5.1.x (From scratch)? section 3D-Model handling

Thanks Rene, I’ll read that …

Ok, I have read your explanation for assigning one 3D model to one footprint. For a single footprint it is playable. In my case, I have more than 100 directories, for each more than 100 files in .wrl or wings format, by working in this way it should take me days or weeks to assign my 3D footprints. Especially since most of the footprints of the Kicad version are in 2D and not in 3D so most of the time unusable to design a full-size project. Yes I know we will say that Kicad is not a 3D CAD tool, but it is clear that to make a realization from A to Z it is often necessary to take into account the 3D shape of the components to put on a PCB . On versions prior to V5.xX I just copied my directories to the Kicad installation directory (in general, C:\Program Files\KiCad\share\kicad\modules\packages3d) and voila !!!
But here it does not work like that with version 5. What is the work around ? if they are one ? Thank you.

Are these your own 3d models for your own footprints? If so then the same workflow as in version 4 should still work. (Your footprints should after all already have the 3d model assigned if it worked in the past)
It might however be the case that you need to prefix the path with a path variable as version 4 did that implicitly (adding this prefix is easily done with a text editor like atom). I would suggest your own path variable pointing to a directory in your user profile.

If you show the 3d settings (in a screenshot) of one of your footprints then i can say more about this.

If these are models for footprints of the official library of version 4 then note that all footprints and therefore 3d models changed their name in the large pre version 5 library reorganization. This means the version 5 footprints expect the 3d models to be named differently than the version 4 equivalent did. (every footprint expects the 3d model to live in a “library” of the same name as the footprint library and have the same name as the footprint. This has always been the case!)

Additionally, be aware that we threw away most old 3d models with good reason. Especially ones made with wings no longer fit the modern mechanical CAD centred workflow. Most importantly they were all scaled wrong. (required the footprint to define a scaling factor which is a no go for mCAD integration.) See What is the difference between step and wrl 3d models?

Thank you René for the explanations, my personal 3D directory contains different types of files (from the start I have accumulated different types of files for the most part in downloads and now I have extensions in .step, .wrl, .wings). So to make it simple I would like to assign a footprint from Molex to a connector of my electrical diagrams. As explained in your document, I have to add the Path of my 3D directory :


Here is : KICAD_3D_MOD

Now I open eeschema and select the connector to assign the 3D shape :


By cliquing on Footprint that open the footprint library browser :

Here my directory with the Phoenix_Screws.3dshapes :


Not visible on library browser … I joint one of the file as sample :

Pheonix_MKDS1.5-3pol.wrl (196.6 KB)

Looking more into Path, it seems KICAD Ignore my settings for personal directories, ONLY Kicad path (from original installation) work !

You are confusing the folders. Why would your 3d models folder show up in footprint browser? It shows footprint libraries and only those that are already defined in global or project lib table.

To add 3d models you need to edit footprints, no way around that.

1 Like

Hello qu1ck, you’re right, but on the actual organisation of Kicad V5, 3D models are part of the footprint directory. After a new installation 3D directories are inside : C:\Program Files\KiCad\share\kicad\modules\packages3d :
The only way to view them are to open the footprint editor (for now) to show the item in 3D. Another way is to use the FreeCad 3D tool to view it.

Finally I found a solution to solve my problem, I allow myself to resume:
When creating a PCB project usually during the insert of a component on the schematic (eeschema) it is good to give it a reference, a number and as far as I am concerned a footprint (2D) and better a 3D footprint if possible. When generating the netlist for export to the creation of the PCB (Pcb_new), all the names and footprints of the components to be placed facilitate placement and future packaging with the (optional) 3D view.

With version 5 of Kicad it seems difficult to place this option (the good view in 3D and not in 2D, like most of the footprints) in the schematic part, so I choose a footprint quite close to what I have need and I generate my netlist with this footprint.

Then when importing into Pcb_new, I place my components, then I edit the footprint in order to change the model :


Then I remove the first footprint

Final placement with desired 3D footprint

I know this is not an easy way but it work …

1 Like

You need to ensure that you select the footprint that fits your component. Otherwise, you will find it hard to fit your parts once you get your PCB back from production.

The Micro-fit footprint you selected has a pin pitch of 3 mm. I am not sure MKDS is available in that pin pitch. (The closest i could find is 3.5 mm).

The footprints for phoenix MKDS series are in the TerminalBlock_Phoenix library. We do however not have footprints for the 3.5/3.81 mm series at this point in time so you would need to make your own footprints.

Hi Rene, of course double check is better before manufacturing. Here is just an example how to substitute a footprint from eeschema to Pcb_new later.
For the footprint I choose a 3 pins Molex Connector with 2.54mm pitch but 3D model nothing to do with my real expectation, later editing footprint into Pcb_new I select the corresponding as possible to my connector (on my lib I’ve TerminalBlock_Phoenix_MPT-2.54mm_3pol).

That’s brave. I wish that you never learn the hard way why i say that.

Fortunately, this is an exception, in most cases the footprints correspond to my needs. It neither has that for new components or the I am obliged to proceed in this way or to create the component from scratch. But it’s not too often!

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.