Turn on advanced configuration option

Maybe I shouldn’t do this if I can’t figure it out ha but I am trying to figure out how to to turn on the beta “ImportSVG” option.

Bug #1821571 and #1827165 discuss turning this option on. I mostly just want to experiment. The directions are pretty straightforward and say to,

"Enable it by creating a file named kicad_advanced in the config directory with the content “EnableSvgImport=1”.

I am not sure where the config directory is…also does the file named kicad_advanced require an extension of some sort?

  • Linux: The user’s home directory + .config/kicad (= $HOME/.config/kicad or ~/.config/kicad)
  • Windows XP: “C:\Documents and Settings\username\Application Data” + kicad (= %APPDATA%\kicad)
  • Windows Vista & later: “C:\Users\username\AppData\Roaming” + kicad (= %APPDATA%\kicad)
  • OSX: The user’s home directory + /Library/Preferences/kicad
1 Like

Answered also in Where are the configuration files (settings, library tables)? FAQ article :slight_smile:

1 Like

I forgot about that FAQ article. I copied it from my library management one could have linked yours.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.