[SOLVED] wxPython error while building from source


I’m having issues with compilation of Kicad sources on Linux Debian while using the following install script: https://gist.github.com/ceremcem/4024c0a4a8649e858855

The error is:

In file included from /home/ceremcem/kicad_sources/kicad/scripting/python_scripting.cpp:30:0:
/home/ceremcem/kicad_sources/kicad/scripting/python_scripting.h:16:38: fatal error: wx/wxPython/wxPython.h: No such file or directory
compilation terminated.
pcbnew/CMakeFiles/_pcbnew.dir/build.make:145: recipe for target 'pcbnew/CMakeFiles/_pcbnew.dir/__/scripting/python_scripting.cpp.o' failed
make[2]: *** [pcbnew/CMakeFiles/_pcbnew.dir/__/scripting/python_scripting.cpp.o] Error 1
make[2]: *** Waiting for unfinished jobs....

Since wxPython is installed already, I can not get why wxPython can not be found.

1 Like

Did you try

‘make clean && make’


I tried cloning repository freshly and did a upgrade && dist-upgrade, and then run the script; result is the same.

Update: After installing python-wxgtk3.0*, everything worked OK.


For anyone else stumbling onto this page trying to build from source, I just did it in Linux Ubuntu. It was extremely challenging, so I took careful notes. Here are my build notes:

  1. Building from source in Ubuntu, it thinks I have swig2.0 when I have swig 4.0
  2. https://bugs.launchpad.net/kicad/+bug/1804771
1 Like