[SOLVED] Problem when opening KiCad

I have noticed a problem. For the version, see below.

  1. Open an existing kicadd_pro file
  2. (try to) open the PCB file.
    → 1 click : doesn’t open
    → 2 clicks: does something, opens an empty file
    and pops up a window saying: PCB xxx.kicad_pcb is already open by ‘me’ at ‘pc_name’.
    Interleaved saves may produce very unexpected results.
    Here: 2 buttons. Open Anyway or cancel.
    When choosing open anyway, it works normally. But what is the cause of this phenomenon?


Addendum: I should also say that when it happened this morning, it was a fresh boot, there was no application running (i.e. no other Kicad file open, and in short no application at all).

Application: KiCad x86_64 on x86_64

Version: 7.0.7-7.0.7~ubuntu23.04.1, release build

wxWidgets 3.2.2
FreeType 2.12.1
HarfBuzz 6.0.0
FontConfig 2.14.1
libcurl/7.88.1 OpenSSL/3.0.8 zlib/1.2.13 brotli/1.0.9 zstd/1.5.4 libidn2/2.3.3 libpsl/0.21.2 (+libidn2/2.3.3) libssh/0.10.4/openssl/zlib nghttp2/1.52.0 librtmp/2.3

Platform: Ubuntu 23.04, 64 bit, Little endian, wxGTK, ubuntu, wayland

Build Info:
Date: Aug 13 2023 23:14:43
wxWidgets: 3.2.2 (wchar_t,wx containers) GTK+ 3.24
Boost: 1.74.0
OCC: 7.6.3
Curl: 7.88.1
ngspice: 38
Compiler: GCC 12.3.0 with C++ ABI 1017

Build settings:

This probably means KiCad crashed at some point while you had the project open, which leaves behind a lockfile. You can look for the lockfile in the project directory and delete it.

1 Like

This file @roboya , the .lck file


1 Like

I too had this problem and removed the file you suggested and all is well :smiley: So solved for me…cheers.

1 Like


Sorry for the delay, I was busy on other things. It didn’t happen in the meantime, but it’s good to know.
As I had a saved zip of the project, I just unzipped the latest one. I could have saved time.
So consider it solved for me too.


1 Like

FWIW, deleting the .lck file actually caused the schematic file to no longer open, it claimed it could not fin other associated files. To get into my schematic, it took a few click sequences to figure out: first File->close the project, then open it again, try to open the .sch file, deal with the lock warning by clicking “open anyway”. I could not find a way around this, so I made a new project and copied my work over to that. Fortunately I wasn’t too deep into things yet. The schematic I opened in the old project and cut and pasted over to the new, and the library files I copied to the new project directory and set up new project library references in the new project.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.