[solved] Import Arduino Eagle project closes KiCAD

Hi, I’m totally new to KiCAD but I’ve used several other schematic capture and PCB layout tool from several other vendors over the years as a practicing EE.

I’m starting a hobby project based on an Arduino, and I want to include the Arduino Uno in the layout for my project.

In a Windows 10 pro VM I installed a fresh copy of KiCAD kicad-5.0.1_3-x86_64.

At some point I was asked if I wanted to use graphics acceleration, I said NO.

Downloaded Eagle .sch and .brd files from Arduino.cc.

Started KiCAD, Selected File:Import Project:Eagle Project

In the import process I got this message:

" You have run Pcbnew for the first time using the new footprint library tabel method for finding footprints. Pcbnew has either copied the default tabel or created an empty table in the kicad configuration folder. You must first configure the table to include all footprint libraries you want to use. See the “Footprint Library Table” section of the cvPcb or Pcbnew documentation for more information."

Clicked OK to move on.

Looked like an image of the schematic appeared then the import process continued on to import the PCB

Got the spinning circle for a bit then KiCAD just closed altogether.

The following files were created in my destination directory before KiCAD Closed.

So my question is: What has happened? How do I fix it?

Pointers greatly appreciated.

Thank you


5.0.1 has a known error with Eagle import. You can try the 5.0.2 dev builds http://downloads.kicad.org/windows/testing/5.0/

Thank you Seth, I will try the 5.0.2 build and let you know if I still have problems.


It worked with the 5.0.2 dev build.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.