[SOLVED] External Plugins Directory Location for Ubuntu


#21

import pcbnew
pcbnew.GetWizardsBackTrace()
‘Traceback (most recent call last):\n File “/usr/lib/python3/dist-packages/pcbnew.py”, line 3579, in LoadPluginModule\n mod = importlib.import_module( ModuleName )\n File “/usr/lib/python3.6/importlib/init.py”, line 126, in import_module\n return _bootstrap._gcd_import(name[level:], package, level)\n File “”, line 994, in _gcd_import\n File “”, line 971, in _find_and_load\n File “”, line 955, in _find_and_load_unlocked\n File “”, line 665, in _load_unlocked\n File “”, line 678, in exec_module\n File “”, line 219, in _call_with_frames_removed\n File “/home/don/.kicad/scripting/plugins/pnpassist_action.py”, line 7, in \n import matplotlib.pyplot as plt\nModuleNotFoundError: No module named ‘matplotlib’\nTraceback (most recent call last):\n File “/usr/lib/python3/dist-packages/pcbnew.py”, line 3579, in LoadPluginModule\n mod = importlib.import_module( ModuleName )\n File “/usr/lib/python3.6/importlib/init.py”, line 126, in import_module\n return _bootstrap._gcd_import(name[level:], package, level)\n File “”, line 994, in _gcd_import\n File “”, line 971, in _find_and_load\n File “”, line 955, in _find_and_load_unlocked\n File “”, line 665, in _load_unlocked\n File “”, line 678, in exec_module\n File “”, line 219, in _call_with_frames_removed\n File “/home/don/.kicad/scripting/plugins/pnpassist_action_sysFW.py”, line 15, in \n import matplotlib.pyplot as plt\nModuleNotFoundError: No module named ‘matplotlib’\n’


#22

I do have another kicad folder here:

don@don-ThinkPad-X240:~/.config/kicad$ ls -a
.   3d        fp-lib-table  kicad_common  PyShell_pcbnew_startup.py
..  eeschema  kicad         pcbnew        sym-lib-table

But none of these are directories. In OSX, there’s the ‘Show Package Contents’ option- which is how I recall getting to the the script folder I use on my OSX kicad.


#23

@dongero you already put the plugin in the right directory, now you have missing dependencies as I predicted. So leave the plugin as is and install some packages, namely matplotlib (see last line of the output you just copied in your post). After that if plugin still doesn’t appear in menu repeat the process.


#24

Just be careful to install them for the same python installation/version which KiCad uses.


#25

Ah! Amazing! It’s working now - Python3 was missing matplotlib - I had it installed in Python2.7

This was helpful! I thought Kicad was still using Python2.7, but that’s only with IOS - thanks for the heads-up

Thank you all for the help! I learned a lot!