SOLVED: Compiling V5 RCs on Debian


#21

Update on my build - all went well. The only issue I have now is that pcbnew fails to load sigh
This could be due to a possible conflict within that compile section (pcbnew) as it does state that is requires ssl1.0.2 (or something like that - I been up too long watching this) and that causes some conflict with curl (I recall seeing that at that point).

Been up all night tinkering with this compile and a vbox install of SID. Need sleep as its now 6:40 am here.

Any insight would be appreciated from those here that had a successful compile. Please check the other modules to see that they come up.


#22

Exact I’ve the compile warning here :
> /usr/bin/ld: warning: libssl.so.1.0.2, needed by /usr/lib/i386-linux-gnu/libcurl.so, may conflict with libssl.so.1.1

/usr/bin/ld: warning: libcrypto.so.1.0.2, needed by /usr/lib/i386-linux-gnu/libcurl.so, may conflict with libcrypto.so.1.1

I don’t understand the conflict but…


#23

I’ve create a simple example with a connector, a resistor and a capacitor.

When I want open CvPcb, it’s not possible because of libkicad_3dsg.so.2.0.0 is missing.

Exactly, it’s in the kicad-source-mirror/build/release/3d-viewer/3d_cache/sg folder but not installed by the sudo make install command.
Were I need to put it?

After, I decide to run kicad from Terminal, to see isues, the first is

Gtk-Message: Failed to load module “atk-bridge”
that can be fixed by installing libatk-adaptor

Now, I’ve try to start PcbNew but it crash immediately…


#24

@Chris60601, @gilou, I had to run “ldconfig” as root. After that pcbnew and cvpcb worked. So it was about the system’s library paths, not about KiCad installation per se.


#25

Bingo! That did it!
I am now up and running with RC2.


#26

Thanks
That solve the problem!


#27

liboce-foundation-dev
OpenCASCADE Community Edition CAE platform library development files

liboce-ocaf-dev
OpenCASCADE Community Edition CAE platform library development files
(this one added quite a few dependencies)


#28

Everyone -
I want to thank you all again for helping me through compiling.
Thanks a bunch

Cheers
Chris


#29

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.