[SOLVED] Application failed to load

Hello, I just installed Kicad v7.0 and when I want to open the schematic editor I have these errors:
15:35:28: Failed to load shared library ‘/usr/bin/_eeschema.kiface’: /usr/bin/_eeschema.kiface: undefined symbol: _ZNK13wxGLCanvasX1115IsShownOnScreenEv, version WXU_3.2
15:35:28: Failed to load kiface library ‘/usr/bin/_eeschema.kiface’.
15:35:28: Error loading editor.
15:35:28: Application failed to load.

Is there someone who can help me ? thanks for your help !
Patrick MULOT

It might help if you let us know what version of KiCad you are using (and your OS details) . . . can you paste your version info here please, you can get it from KiCad > Help > About KiCad > Copy Version Info


Here the infos you want :slight_smile:
Application: KiCad x86_64 on x86_64

Version: 7.0.7-7.0.7~ubuntu22.04.1, release build

wxWidgets 3.2.2
FreeType 2.11.1
HarfBuzz 6.0.0
FontConfig 2.13.1
libcurl/7.81.0 OpenSSL/3.0.2 zlib/1.2.11 brotli/1.0.9 zstd/1.4.8 libidn2/2.3.2 libpsl/0.21.0 (+libidn2/2.3.2) libssh/0.9.6/openssl/zlib nghttp2/1.43.0 librtmp/2.3 OpenLDAP/2.5.16

Platform: Ubuntu 22.04.3 LTS, 64 bit, Little endian, wxGTK, ubuntu, wayland

Build Info:
Date: Aug 13 2023 23:14:49
wxWidgets: 3.2.1 (wchar_t,wx containers) GTK+ 3.24
Boost: 1.74.0
OCC: 7.5.2
Curl: 7.88.1
ngspice: 38
Compiler: GCC 11.4.0 with C++ ABI 1016

Build settings:

And my pc : LENOVO V17-G2-ITL 64bits - 16Gio - 11th Gen Intel® Core™ i5-1135G7 @ 2.40GHz × 8
UBUNTU 22.04.3 LTS gnome 42.9 Wayland

In preferences - schematic editor - display options
Try selecting fallback graphics

When I click on Preferences I got this message :slight_smile:

16:20:24: Failed to load shared library ‘/usr/bin/_eeschema.kiface’: /usr/bin/_eeschema.kiface: undefined symbol: _ZNK13wxGLCanvasX1115IsShownOnScreenEv, version WXU_3.2
16:20:24: Failed to load shared library ‘/usr/bin/_pcbnew.kiface’: /usr/bin/_pcbnew.kiface: undefined symbol: _ZNK13wxGLCanvasX1115IsShownOnScreenEv, version WXU_3.2
16:20:24: Failed to load shared library ‘/usr/bin/_gerbview.kiface’: /usr/bin/_gerbview.kiface: undefined symbol: _ZNK13wxGLCanvasX1115IsShownOnScreenEv, version WXU_3.2
16:20:24: Failed to load shared library ‘/usr/bin/_pl_editor.kiface’: /usr/bin/_pl_editor.kiface: undefined symbol: _ZNK13wxGLCanvasX1115IsShownOnScreenEv, version WXU_3.2

How did you install it? Something’s wrong with your wxWidgets.
Looks like a mismatch between KiCad’s KICAD_USE_EGL and wxWidgets’ wxUSE_GLCANVAS_EGL flags.

In the manner indicated by Kicad for Ubuntu:

sudo add-apt-repository ppa:kicad/kicad-7.0-releases
sudo apt update
sudo apt install kicad

Check out this thread: [SOLVED] Kicad v7 on Ubuntu 22.10 (Kinetic)

I use an UBUNTU LTS distribution ! I don’t want to use anything else. I have enough problem yet !

The exact Ubuntu version doesn’t matter for the fixes in that thread.


ldd /usr/bin/_eeschema.kiface | grep wx

See if there’s any paths that are in /usr/local, then remove them.

before removing anything, here is the result of your question :slight_smile:

patrick@patrick-Lenovo-V17-G2-ITL:~$ ldd /usr/bin/_eeschema.kiface | grep wx
libwx_gtk3u_gl-3.2.so.0 => /usr/local/lib/libwx_gtk3u_gl-3.2.so.0 (0x00007f407557f000)
libwx_gtk3u_aui-3.2.so.0 => /usr/local/lib/libwx_gtk3u_aui-3.2.so.0 (0x00007f4073b56000)
libwx_gtk3u_html-3.2.so.0 => /usr/local/lib/libwx_gtk3u_html-3.2.so.0 (0x00007f4073a75000)
libwx_gtk3u_core-3.2.so.0 => /usr/local/lib/libwx_gtk3u_core-3.2.so.0 (0x00007f4073000000)
libwx_baseu_net-3.2.so.0 => /usr/local/lib/libwx_baseu_net-3.2.so.0 (0x00007f4075532000)
libwx_baseu-3.2.so.0 => /usr/local/lib/libwx_baseu-3.2.so.0 (0x00007f4072c00000)
libwx_gtk3u_propgrid-3.2.so.0 => /usr/local/lib/libwx_gtk3u_propgrid-3.2.so.0 (0x00007f4073960000)
libwx_baseu_xml-3.2.so.0 => /usr/local/lib/libwx_baseu_xml-3.2.so.0 (0x00007f407551b000)
libwx_gtk3u_stc-3.2.so.0 => /usr/local/lib/libwx_gtk3u_stc-3.2.so.0 (0x00007f4072800000)

Now, what have I to do exactly ? I am not familiar with this kind of operation ! and I don’t want to kill my system !

Looks like you’ve locally build a version of wxWidgets without the required interfaces for KiCad. One option is to delete (or move) all wxWidgets/python/KiCad related files from /usr/local/lib so KiCad will use the standard system libraries, but without knowing why you’ve build them locally and what else might use these, that might not be safe to do.

I don’t know if there is a way to make KiCad ignore the libraries in /usr/local.

You could also reinstall your system or start Kicad in a VM or Container/Flatpak.

I program in C++ with wxWidgets version 3.0.5 and, and i generate this two version for my use.
Is that who make panic to Kicad ? if it is the case, I will install Kicad differently ! it’s damage that this software can’t work with the others software !

how cant I install Kicad in a Container/Flatpak and how can I use it ? I don’t know this kind of use.

If you’re building wxWidgets yourself, configure it with flags

--with-opengl --disable-glcanvasegl

and it should work.

Alternatively, to use Flatpak, install Flatpak and then install the Flatpak version of KiCad: KiCad | Flathub

Note: I haven’t tested the Flatpak version of KiCad. Running in a Flatpak Container might have some limitations.

Another alternative is to set LD_LIBRARY_PATH before running KiCad:

export LD_LIBRARY_PATH="/lib/x86_64-linux-gnu"

Hello everyone and thank you for your help!
Well, I cleaned up my wxWidgets 3.0.5 and by running “sudo make uninstall” for both.
Then I re-installed Kicad and now it works correctly.
I’ll see about re-installing my wxWidgets later!
thank you again everyone.


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.